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Introduction 

Introduction 
With increasing use in digital images and multimedia, the need for organizing and controlling workflow is becoming a 
necessity, especially when handling large amounts of digital information. Picsara is a modular based image archiving, 
image analysis, and image processing system that helps solve many imaging problems for both small and large 
laboratories, hospitals and other enterprises. 

Basic imaging functions are built into the program to improve image quality, add annotations and much more. With help of 
the optional modules Picsara can become a powerful image analysis system great for many special applications, such as 
weld and hardness testing measurements.   

 

The Picsara program can be used to capture, create, process, organize and measure images.  

 

Picsara is highly modularized software. This has two major advantages: 

1. Maximizing the ease-of-use and giving the customer the freedom to choose desired modules and functions. 

2. Minimizing cost of investment and cost of ownership. 

 

Picsara can be anything from a simple viewer, to a highly sophisticated image analysis machine, with support for state of 
the art digital video cameras, and many other features. 

 

 

Please view the Add-on modules overview for more information on the different modules. 

 

Declaration of Conformity 
 

 

News in this version 
Version 8.9 adds several new interesting features to Picsara, such as: 

• Excel Interactive Measurement mode, for automatically populating a Excel Spread sheet 

• Support for Excel report templates,  

• Improved Distance measure tool  

• Auto white in live video using pipette function 

• Added Focus aid to Camera toolbar 
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Service and Support 
This software is guaranteed against defective behavior for a period of one (1) year from the date of receipt by the 
customer.  

If for any reason you need support on this software, please contact your software vendor. In all contacts with your vendor, 
please have the following information available: 

 

1. Software License number  

2. Invoice number 

 

For a list of contacts, please see Contact Information below. 

 

 

 

Contact information 
 

Optilia Instruments AB 
Djupdalsvägen 22 

S-192 51 Sollentuna 

SWEDEN 

Tel: +46 (0)8-35 33 60 

Fax: +46 (0)8-35 33 63 

E-Mail: info@optila.eu 

Web: www.optilia.com 
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Installation 

Hardware requirements 

CPU   Minimum: 2.4 GHz  Pentium 4  

    Recommended: 3.4 GHz or higher, Pentium 4  

Network card  Minimum: A Network card is strongly recommended 

   The network card should be installed before the software is installed 

Memory   Minimum: 256 MB 

    Recommended: 512 MB  

Hard Disk Drive   Minimum: 10 GB of Free Space 

    Recommended: 40 GB of Free Space 

Optical Disk Drive  Minimum: CD-ROM 40x 

    Recommended: DVD-ROM 8x 

Video Display  Minimum: XGA (1024x768 at 32bbp)  

    Recommended: UXGA (1600 x 1200 at 32 bpp) 

    Observe, recommendation may differ for different cameras 

Video Adapter  Minimum: 4x AGP 16 MB 360 MHz RAMDAC 

    Recommended: 8x AGP 32 MB 400 MHz RAMDAC 

Devices   Minimum: 1 Parallel Port, Mouse, Keyboard 

    Recommended: 2 Parallel Ports, Mouse, Keyboard 

    CD/DVD Burner, IEEE-1394 FireWire Port 

 

Note: Some accessories, such as digital video cameras etc, might require higher specifications than the above. 
Please consult your accessory manual 

Software requirements 
Operating System  Minimum: Windows 2000 Professional including all updates 

    Recommended: Windows XP Professional including all updates  

Office Suite  Minimum: MS Office 2003 Small Business including all updates 

    Recommended: MS Office XP Professional including all updates 

Installing a Frame Grabber 
A frame grabber digitizes the analog video signal into a digital image making it usable for a computer. 

Picsara supports several types of frame grabbers, for instance standard DirectX compatible frame grabbers, Matrox 
Meteor-II/Std, and Matrox Meteor-II/MC. 
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For information about how to install Matrox hardware, consult the Matrox Meteor-II installation guide.  

If using the Matrox Meteor-II frame grabber with Picsara, it is necessary to install the appropriate drivers and MIL. (MIL 
Lite or MIL). 

None of the Picsara modules require a full version of MIL. Having a Full version of MIL is only required if another 
application, such as Buehler Omnimet MHT is installed.  

If a complete system including a Matrox Meteor-II card was purchased, the reseller can normally supply the MIL Lite 7.5 
free of charge. If the card was purchased from another supplier, the driver must be purchased separately from the 
supplier.  

Refer to the table below for the recommended version of MIL and graphic card. 

Table I 

Operating system Mil version Graphic card 

Windows 2000 MIL 6.1 Lite Matrox G450 

Windows XP MIL 7.5 Lite Matrox G550 

 

MIL-Lite doesn't require any license. If using the full version of MIL on the computer, a MIL Runtime License from Matrox 
is required.  

A MIL-license is tied to the computer when creating the license. In some cases the MIL license can stop working if the 
hardware is changed or the system is upgraded. If this occurs, contact a Matrox reseller for assistance in upgrading the 
MIL-license. This only applies to the full version MIL and not MIL-Lite. 

Note: MIL-Lite and the full version of MIL cannot be installed at the same time. 

1. Connect the camera to the frame grabber using a video cable. 

• If using an original Matrox cable to the Meteor-II, connect the 44-pin connector to the corresponding D-sub 
connector on the frame grabber. 

• If connecting a composite color (only Meteor II/Std) or a black and white camera, use a single video cable with 
BNC-video contacts. 

Note: Never connect cameras to both the cable and BNC connector simultaneously. 

Installing a DirectX Compatible Camera 
Before installing a DirectX device, make sure Picsara is not running. 

DirectX is part of the operating system and is pre-installed in Windows XP and Windows 2000. If the computer does not 
have DirectX installed, install the latest available DirectX installation. Consult www.microsoft.com/directx for more 
information. 

Most DirectX devices are connected via USB2 or FireWire. Normally you should install the device driver (WDM driver) for 
the device before connecting the device to the computer. Except when using DV cameras, they have a built in driver in 
Windows XP. 

After installing the device driver/WDM driver connect the camera to the computer, one of three messages will normally 
appear before the installation process is ready. If, at a later time, the camera is attached to another USB or FireWire port 
on the same computer, you normally need to re-install the driver for that port as well. If different ports will be used at 
different times, it is recommended to initially install the driver on all ports.  

Note: Currently Picsara is verified to work with DirectX version 9.0c, although any minor version should work too. 

Note:  Only a computer administrator can install hardware. 
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Installing the Software 
Installation of the Picsara software can only be done by a user with administrator rights. 

Note: It is recommended to uninstall any earlier versions of Picsara before installing version 8.9.  

1. Insert the CD into the CD-ROM drive. 

2. The installation program will automatically start. 

• If the program does not automatically start, double click setup.exe on the installation CD. 

When the Picsara installation is complete, Picsara can be located: Start -> All Program -> Bildanalyssystem-> Picsara 8.9. 

Upgrading the Software 
Picsara 8.9 can be installed simultaneously with earlier (major) versions of Picsara. Installation of Picsara 8.9 will not 
delete or change earlier versions of Picsara, but in order to avoid confusion it is strongly recommended to un-install earlier 
versions of Picsara before upgrading. 

Note: If installing multiple versions of Picsara, it’s assumed that they are installed in the same order as they are 
released.  For instance 8.8 must be installed before 8.9,  or the software will not work as expected. 

 Note: If re-installing Picsara 8.9 it is possible to choose not to re-install the demo database 8.9, in order to avoid losing 
data. Upgrading Picsara will not upgrade existing databases. Please read Upgrading an old database on how to 
upgrade an old database. 

Note: Picsara can be upgraded with any version that was released within a year counted from the date the software 
was originally registered. If there is a request to upgrade to a newer version, please contact your distributor for 
more details on how to upgrade the license. 

 

Starting for the first time 
When the Picsara installation is complete, start Picsara using the Windows Start command. Picsara is installed in the 
folder Start-> All Programs -> Bildanalyssystem -> Picsara 8.9 

 

When running the application for the first time, you should register your software license. For details, please read License 
Registration. If you want to evaluate the software, or register at a later time, press the Register later. button 

 

 

Note: The Picsara program may be located in different folders depending on the operating system. 

Note: If using a laptop computer with a network card and a docking station, disconnect the laptop from the docking 
station before registering Picsara. If the laptop is not removed from the docking station during the registration, 
Picsara may not work properly anytime the laptop is separated from the docking station. 

 

Upon completion of the registration, the application is launched. If you have purchased the database module, the Create 
database wizard will show up.  
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Software Registration 

Software Registration, Overview  
The Picsara software must be registered before it can be used. During the registration, the application exchanges some 
important information with the manufacturers license server, in order to activate the license on your computer. As part of 
this process, the application and License server will exchange an Activation code, which will enable the application and 
the add-on modules you have purchased. If you do not have the possibility to register over Internet, it is also possible to 
register manually over phone. 

Note: During the registration process you will be asked to enter some credentials. Bildanalyssystem AB guarantees 
that data will not be used for anything but improving service and support. The information is kept securely, and 
will NOT be sold or passed to a third party. In case you don’t want to register your credentials, simply omit this 
step and continue. (Observe, Country is the only mandatory field). 

When starting the application for the first time, or when starting an unregistered copy of the software, the following dialog 
will appear: 

  

 

Press Register now, in order to start the registration process. 

Note: It is possible to run the software for a limited time (30 days) without registration. If you want to run the software 
temporarily on a computer, press Register later, and use the software without completing the registration. Read 
more under Evaluating the software. 

Select if you want to register over internet, or register by phone.  

Registration over Internet 
Using the Register over Internet method, license information is exchanged over the internet with the license server, and 
the application is automatically enabled with its corresponding modules. Select Register over Internet and the following 
dialog will appear: 
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Fill out the form, and press Next. The license will be verified against the license server. Upon success the following dialog 
will appear: 
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Note:  Your license number is printed on your CD or Jewel case; alternatively you can find your license number on 
your invoice or a separate license agreement. 

 

Note: Please observe that a license can only be registered on one computer. In the event of a serious failure, the 
software can be re-registered on the same computer an infinite number of times (e.g. after a complete 
reformatting of the hard disc). Before moving your license, please contact your software vendor first. 

Registration over Phone 
When registering the software over the phone, call any of the numbers displayed in the registration dialog: 

You will need to have both your license number and your Site-ID available when making the call.  
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Evaluating the software 
It is possible to run the software without a license for a limited time (15 days). In the registration dialog, press Register 
later and select the version to evaluate. 

Note:  It is possible to register the software at a later time from within the application, or by simply restarting the 
software. 
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Basic functions 

Basic functions, Overview 
Regardless of add-on modules, Picsara offers some basic functionality. Even though there are some interesting features 
in the base module, its full potential will be unleashed when one or more modules are added. 

 

The Basic functions include: 

• Loading and saving of images 

• Displaying and zooming images 

• Limited interactive measurements 

• Limited image processing 

• Compare image functionality 

• Image annotations 

 

 

Loading and Saving Images 
Picsara can import (open) and export (save) image files.  

To open an image: 

Select File -> Open image… 

The following image file types can be opened.  

• Tiff:   A standardized, uncompressed image format.  

• Jpeg:   A standardized, compressed image format.  

• Img:   A Buehler specific image format used with earlier versions of Omnimet 

• Bitmap:  A Windows bitmap. A common, uncompressed image format. Observe: Several bitmap formats 
exist. Only Windows bmp format is supported. 

• PNG:   An older image file format often used in relation to the Web. 

• Kodak Photo CD:  Kodak photo proprietary image format.  

 
To save the current image: 

Select File -> Save image… 

The image can be saved in the following formats: 

• Tiff: A standardized, uncompressed format. Save images using this format if the image quality is more important 
than the file size. Images will have a much larger file size using this format. 
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• Jpeg: A standardized, compressed format. Save images using this format if the file size is more important than the 
image quality. The file compression size can be selected in the System Preferences dialog box, under the General 
Tab. 

• Bitmap: A common, uncompressed format. Use this format only if the Tiff and Jpeg formats cannot be used.  

Please read the Tech note "Image Formats", for more information regarding image file formats. 

 

Note: It is recommended to use the TIFF image format for images that may be used for image analysis in the future. 
File formats with image compression will affect the image quality, which in turn can affect measurement results 
in the future. 

 

Note: A database is recommended instead of saving images as files. The calibration and text will be stored with image 
and the image will be easier to find. Calibration information is not stored when images are saved as individual 
files. 

Viewing the Image 
The image is always viewed in the main window.  

Depending on the resolution of the monitor and the size of the current image, it might be necessary to change the view. 
Normally when loading (or in any other way importing) an image, the image is zoomed to fit the screen.  

The presentation can be changed manually: 

 

• To increase the display zoom: 

o Select Image -> Digital zoom+, or click F3.  

o Zoom increases by 20%. If the image does not fit the window, the center of the image will be 
displayed. 

• To decrease the display zoom: 

o Select Image -> Digital zoom-, or click F4.  

o The zoom decreases by 20%.  

• To display the image at the original resolution (100%): 

o Select Image -> Restore zoom, or click Ctrl-F2.  

• To adjust the image to fit the main window:  

o Select Image -> Fit to screen, or click F2. 

 

If the image does not fit the screen, it is possible to pan the image using the Pan Tool: 

Select Image -> Pan image. A "hand" appears on the main screen. Drag or move the image to the desired position.  

Note:  Regardless of the display zoom and Pan, calibrated measurements can be performed. If measuring very small 
objects, the accuracy can be improved by zooming in the image. 
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Note: Picsara uses interpolation for both negative and positive zoom. Normally this will make most images appear 
nice, regardless of display zoom. However, magnifying an image using this method does not increase the 
resolution of the image, only its visible appearance. Do not over estimate this functionality. 

Displaying Image information and EXIF data 
It is possible to display Image Information superimposed on the image. Database Meta Data and/or Camera Meta Data 
(EXIF data) can be viewed. 

In the View Menu, check the requested alternative(s). 

 

It is also possible to select if the font characters are displayed in black or white. 

In the View Menu, select the appropriate color. 

Magnifying parts of the Image 
Use the Magnifying Glass to view details, especially in high-resolution images. 

1. Click the Magnify button. 

2. Place the mouse over the part of the image to enlarge. 

3. Rotate the mouse wheel to adjust image enlargement. 

4. Click any mouse button or click Esc to end the magnification command. 

 

Note: The magnifying glass cannot be used with measuring tools. To measure in an enlarged image, increase the 
zoom (F4). 

 

Importing from Memory Card and other Removable Medias 
Picsara includes a mechanism for easy import of images from various removable sources, such as a memory card, USB 
memory stick or CD-ROMs. The only requirement is that the source should appear as a drive letter in Windows Explorer 
when connected to the computer. 

 

By defining a "Removable Media source" it is possible to instruct Picsara to monitor a certain drive letter. As soon as new 
images are found on this drive, a window will popup in Picsara and show thumbnails of the images that were found. For 
each source, it is possible to define which file types should be loaded. 

 

In addition it is possible to instruct the software to move or erase the images from the source after import. If thumbnail 
images have the wrong orientation, they can be rotated before being imported. 

 

To configure a Removable media source: 

 

1. Open File → System preferences... 

2. Select the Removable Media tab 
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3. Press the Add... button 

4. In the dialog that opens, specify a name for the removable media source and configure other options according to 
your preferences. 

5. Press the Browse... button to locate the removable media drive.  
Note: The device should be attached to the computer to appear in the list. This does not apply to CD-ROM devices 
and other devices that are permanently attached. 

6. Click Ok to close the dialog and exit the system settings. 

 

  

Images found on removable media named "Card reader". 

 

Note:  The same mechanism can be used to monitor a portion of the regular hard disk or network drive. This can be 
useful if an imaging device such as an electron microscope stores its output images directly on a hard disk. 
Simply browse to the folder that should be monitored. Take care not to include folders that are frequently used 
by the operating system. Otherwise Picsara may report new media each time the operating system modifies the 
content of these directories. 

Image processing 
Image processing overview 

The image processing tools are used to change the appearance of images.  
 

There are two groups of image processing tools: 

1. Image filter tools: filters that are applied on the image without changing the original image. Clicking these buttons 
applies the filters on the image. Clicking the buttons again deactivates the filters and returns the original image.  
Image filters: 

• Black and white filter, see Black and white filter  

• Retina filter, see Retina filter  

• Custom filter, see Custom filter and Adjusting color temperatures  

2. Image processing tools: tools that change the original image.  
Image processing tools: 

• White balance, see Changing the white balance  

• Sharpness, see Increasing the sharpness  

• Histogram equalization, see Improving contrast on flat images  
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• Min-Max equalization, see Improving contrast on flat images 

• Rotate image, see Rotating and flipping the image  

• Flip image, see Rotating and flipping the image 

• Crop image, see Crop image  

 

Black and white filter 

Press the B & W (Black and white) button to apply a black and white filter onto the current color image. Press the button 
again to deactivate the filter. 

 

See Adjusting color temperatures on how to change grey scale intensities in a black and white image. 

Retina filter 

Press the Retina button to apply a retina, or red free, filter onto the current image. Press the button again to deactivate the 
filter. 

 

The retina filter is used to improve the contrast in images of eye retinas. The filter excludes red color, enhances green 
color (1.3 x) and then applies a black and white filter on the image. 

 

Custom filter 

The Custom filter is a filter for color temperatures, brightness and contrast. This filter is adjusted in the Custom filter 
adjustments dialog. See Adjusting color temperatures for more information. 

 

Press the Custom button to apply the current custom filter onto the image. Press the button again to deactivate the filter. 

 

Adjusting color temperatures 

It is possible to adjust the color temperatures of an image. 
 

Color temperatures are adjusted in the Custom filter setup dialog, which is opened by pressing the Setup button in the 
image processing toolbar: 

It is possible to: 

• Increase/decrease red tone 

• Increase/decrease green tone 

• Increase/decrease blue tone 

• Increase/decrease brightness 

• Increase/decrease contrast, (default is 100 %) 
 

The user can choose to view color changes in real time by checking the "automatic apply" check box.  
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If the processing of large images takes too long, uncheck the automatic apply check box. After making the adjustments, 
press the Apply button to see the result. 
 

It is also possible to add a black and white filter to the image and still adjust the color temperatures (now grey tones). 

 

 

Changing the Image White Balance 

It is possible to adjust the white balance of an image. (It is assumed that the image has a white background somewhere). 
 

1. Click the White button. An eyedropper will appear on the screen 

2. Place the eyedropper on an area of the image that is white. 

3. Click the mouse button and Picsara will calculate how to adjust the image to make the background white. 
 

Observe that the operation cannot be undone. 

Increasing the Sharpness 

Increasing the sharpness will increase image details. This command will work better if the image has little or no noise. 

1. Click the Sharpen button 

• When using the Sharpen command, image noise will also be accentuated.  

• Do not increase the sharpness of the same image more than 2-3 times. 
 

Observe that the operation cannot be undone. 

Improving Contrast on flat images  

In Picsara, there are three methods to increase the contrast in an image: 

1. Change the contrast in the Custom setup dialog. 

2. Min-Max Equalization (Max dyn icon) stretches out the intensities in the image to the maximum available range 

• This method works well for most images black and white, and increases the intensity linear over the complete 
image. For instance, if the image includes intensity in the range of 50 to 200, the range will be evenly 
redistributed in the range 0-255. Making the darker pixels become black, and the brighter pixels become white.  

3. Histogram Equalization (Max hist icon) enhances the intensities that are most represented in the image. 

• Increases the difference in contrast among the pixels that are represented the most. This is not a linear contrast 
enhancement, and some distortion will appear in some types of images. Normally this method can be useful if to 
enhance scratches on a polished surface or similar applications. 

 

To use the Histogram filters to increase the contrast in an image, click the appropriate icon. 

 

Using the min-max and histogram equalization methods, affects all of the color channels equally. A slight color shift is 
impossible to avoid in color images. Therefore the functions are recommended for black and white images. Observe that 
the operations cannot be undone. 
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Rotating and Flipping the Image 

Click the Rotate button to rotate the image 90 degrees clockwise. Each click will rotate the image again. Click twice to 
rotate the image upside down. 

 

Click the Flip button to flip (mirror effect) the image on its y-axis.  

Crop image 

To crop an image (change and decrease the size of an image) press the Crop button. A cross-like cursor will be 
displayed. Click the mouse button to draw the outlines of the new image. When you release the mouse, the image will be 
cropped. 

 

Observe that the operation cannot be undone. 

Comparing Images 
Comparing Images Overview 

The Compare images window is used to visually compare two or more images or to compare a series of images with the 
image in the main window.  

To activate the Compare image window: 

1. Select Images -> Compare images...  

 

Up to 20 images can be stored at the same time in the Compare images window. Use the mouse scroll wheel to quickly 
browse between images or click the Page Up or Page Down keyboard keys. 

 

Adding Images to the Compare Images Window 

Images are added to the Compare images window by dragging images from a case or from the main window. 

 

It is possible to set how images are inserted into the Compare Images Window: 

In the File menu, select Settings: 

• Overwrite images at the position where you drop the image, the old image is replaced by the new. 

• Insert images at the position where you drop the image, shifting previous images as needed. 

 

Showing 1, 2 or 4 Images 

The Compare images window can display one (1), two (2), or four (4) images at a time. 

The one (1) image mode is normally used to compare the images in an image suite with the image in the main window 
(live or frozen). 

Two (2) or four (4) image modes are normally used to compare images in the image suite with each other. 

Select number of images to display in the View menu. 
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Using different presentation modes  

There are three ways to scale images in the Compare images window: 

1. Fit to image. Each image is rescaled to a size where it fits the window it is displayed in. Use this mode if you want 
to view the whole image.  

2. Scale as current magnification. The image is displayed with the same magnification as the image in the main 
window. 

• Example:  To compare the size of different objects in the main window against the size of an object in a 
comparison suite, it is necessary that the image is displayed with the same scaling as the image in the main 
window.  

• If the image does not fit in the window it will be cropped and the center of the image will be displayed. 

• The image can be smaller than the window. 

• Do not compare images with large magnification differences. Such as an image with 100x magnification and an 
image with 10x magnification. 

3. Original Size: The image is displayed in 1:1 format. That is, one pixel in the image is equal to one pixel on the 
screen. 

Saving and Opening a Comparison Suite 

All images in the Compare Images Window can be saved as a comparison suite. Associated image calibrations will also 
be saved. 

 

To open a Comparison Suite: 

1. In the File menu, select Open image suite… 

2. Select the image suite to load 

 

To save a Comparison Suite: 

1. In the File menu, select Save image suite… 

2. Type name and location of the image suite and click Save. 

Measurements 
Measurements, Overview 

Picsara is designed to make calibrated measurements. All measurements in Picsara are calibrated so the results are 
displayed with the correct units. Without analysis modules added to the base system, only limited measurements can be 
performed. 

After adding the Analysis Module, and possibly another application module, the system is set up for professional image 
analysis complete with tools for exporting and reporting data. 

Picsara can be used to measure objects in microscopes, macro stands, or captured taken with the help of a handheld 
camera. Picsara is intended to measure objects through devices directly connected to Picsara. It is also possible to 
measure imported images as long as there is a known reference distance in the image. 

Calibrating an Image 

Images imported through File->Open (or imported by any other means) can be calibrated manually assumed there is 
known reference distance in the image. 
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To calibrate a single image: 

1. Select Image -> Calibrate current image. 

2. Match the calibration line to the length of the known object,  

• Try to make the line as long as possible, for better accuracy. 

3. Enter how long the calibration length is and the current unit. 

Note:  If grabbing images from an attached camera or similar device, it is strongly recommended to calibrate the input 
device rather than calibrating each image. See Calibrating an input device for more information. 

 

Note: If a images isstored in the image database, the calibration information is stored as well. 

Measuring the Point-to-Point Distance 

To measure the length or distance between two points use the Length measuring tool. 

1. Select Measurements -> Length. 
Or click the Length button. 

2. Mark the start of the line by clicking the left mouse button, drag the mouse to draw the line and click the mouse 
button to end the line. The measured length will be displayed in the Status Bar. 

3. To measure another object simply repeat step 2 above. 

  

To deactivate the Length measuring tool: 

1. Select Length again or un-click the Length button. 

 

By pressing Ctrl simultaneously as drawing the line, the line will lock at fixed 45 degree angles. 

By pressing Ctrl, and at the same time start a new distance measurement, the measurement will start from the end point 
of the previous distance measurement. 

 

It’s possible to set the length of the end-markers to any distance. Use the File->System Preferences->Measurement 
settings Tab to set the length of the end-markers. 

 

Example:  

Assume you want to measure the vertical distance of a crack that is not 100% vertical, for instance as in sample image 
Crack1.jpg, found in the sample images directory. Make the end-marker distance roughly 200 pixels (as explained above), 
and calibrate the image according to the scale bar in the upper left corner. 

Activate the length measurement tool, and left click without releasing the mouse button, at the start of the crack. Now 
press the Ctrl button on the key-board and move the mouse so the end bar aligns with the end of the crack. Release the 
mouse button and the Ctrl button. 

 

Note: To have the option of adjusting the end points and direction of the line, select the Parallel measuring tool 
instead; see Measuring a width or breath. 

Measuring the Area and Perimeter of an Object 

To measure the area of an object: 
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• Select Measurements -> Area and perimeter. 
Or click the Area button.  

• Using the mouse, click on an arbitrary point on the object edge. 

• Drag the mouse and follow the contour of the object. 

• When finished, release the mouse button and the curve will close.  

 

The Measure the Area and Perimeter of an Object function produces three measurement results, which are displayed in 
the Status Bar: 

• Area 

• Perimeter 

• Open curve measurement, which is equal to the perimeter minus the length of the line that closes the curve. 

Measuring the Width or Breadth of an Object 

Measuring the Width of an object is similar to measuring Length, but with the Parallel tool it is easier to control the 
measurement. 

To use the parallel tool:  

1. Select Measurements -> Parallel, or select Measurements -> Fixed parallel lines -> Vertical distance/Horizontal 
distance, or click the Parallel button. 

2. Mark the start point and drag the mouse without releasing the mouse button to the end position. 

• Fine adjust the width, without changing the angle, by grabbing and moving the "end line". 

• Fine adjust the angle by grabbing and moving the "end anchor" 

• Move the complete measurements by grabbing and moving the "start anchor" 

3. The width result will be displayed in the Status Bar. 

 

 

To measure very thin widths (for example, conductor width on a circuit board): 

1. Click on one side of the conductor and drag out the width. 

2. Concentrate on getting the correct angle for the measurements. 

3. Release the mouse button and adjust the position of the starting point. 

4. Adjust the width by grabbing the end line. The angle will be preserved and the width can be carefully adjusted. 

Displaying Results in the image 

Measure results are displayed in the Status Bar. To see the measurement results next to the measurements in the main 
window select Measurements -> Measure display settings. Check show a text box with the measurements result. 

In Measurement -> Measure display settings… it is also possible to change the color and thickness of measurement lines 
and to change the color, background and font of the measurement results shown in the main window. 
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Deleting Measurements 

• Select Measurements -> Delete last measure to delete the last made measurement. 

o This will also delete the measurement from the result window and the current case (if any) 

• Select Measurements -> Clear measurements to clear all measurements from the screen. 

o This will NOT delete the measurements from the result window or the current case. 

• In the Result window, select File -> Delete all… to delete all measurements from both the screen and the result 
window. 

o This function is only available if the Analysis module is present. 

• In the Case Window, select Case -> Delete all results… to delete all results in the case and on the screen. 

o This function is only available if both the Analysis module and the Database module are 
present. 

 

Tips and Tricks 

All measure tools will work when an image is zoomed or panned. It is much easier to measure a very small object when it 
has been zoomed in. 

Picsara does not support sub -pixel accuracy with measuring because there can be a decrease in the accuracy of 
measurements. 

How to Burn In Measurements in the Image 

Image measurements are performed on a non-destructive layer of the image. If all the measurements are deleted the 
image will still be preserved. 

To save an image with measurements: 

1. Select Measurements -> Burn in measurements to save the results in the image  

2. The top layer is burned into the image and the image is saved together with the measurements. 

• Once measurements are burned into an image, they cannot be removed. 

• In a zoomed in/out image, the burned-in measurements will look different than layered measurements.  

 

 

Note: In order for the measurement results to appear in the burned-in image, they must be visible when the image is in 
the main window. Select Measurements -> Measure display settings and check show a text box with 
measurement result. 

Changing the appearance of measurements 

The visual appearance of measurements can be changed in the following ways 

• Adjust the thickness and color of measurement lines 

•  Font size and color of the text label. 

• Background of the text label can be transparent or solid. 

• Disable appearance of the label. 
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Dialog for adjusting the visual appearance of measurements 

Note:  Changing the visual appearance will affect all measures, except the measurement color, which will affect only 
new measures. The reason for this is that is should be possible to distinguish measurements by their color, 
whereas other display settings are mainly used to enhance the visibility of a measure. 

 

Note:  Use the menu function Measurements → Burn in measurements to image to view measurements on an 
exported image. Images can be exported in several ways, for instance by printing them, saving them as files, or 
in MS Word reports. 

 

 

Annotations 
Annotation, Overview 

It is possible to add various types of annotations to images. The annotations are added "on top of the image" and do not 
destroy the actual image. Because of this, annotations can be moved, changed or deleted without affecting the underlying 
image. 

Images with annotations can be saved in the image database. These annotations can be added, deleted or changed at a 
later time.  

It is also possible to "burn in" annotations into the physical image, making it possible to export the image, including the 
annotations, to any file format. To do this, use the function Burn in Annotations to the Image under the Image menu.  

 

The following annotations can be added to an image: 
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• Lines 

• Arrows 

• Freehand drawn lines 

• Text boxes 

• Rectangles 

• Ellipses 

• Image links 

• Rulers 
 
 

Please read more on adding annotations and changing the appearance of annotations . 

Adding Annotations 

Add annotations by selecting the preferred annotation from the Image menu -> Overlay items… or by pressing the 
corresponding  button in the annotation toolbar. 

For most annotation objects it is possible to change the position and size. Simply activate the object by clicking the object. 
Move or change the size by grabbing the edges or hot spots of the object. 

 

Line and Arrow annotations: 

Simply click and drag to draw the annotation on the image. It is possible to adjust the position of both ends of a line 
annotation. It is also possible to move the complete line by dragging it. 

Line color and style can be changed.  

 

Freehand drawn annotations: 

Click and drag to draw the annotation on the image  

It cannot be resized. It is possible to move the complete outline by dragging it. 

Line color and style can be changed.  

 

Text annotation: 

Click and draw the initial text box. Double-click on the text box to enter the edit mode and add text. Return to the normal 
mode by clicking outside the box. 

The font, border and filling style of a text object can be changed. 

 

Rectangles and Ellipses 

Click and drag to draw the shape on the image.  

Rectangles and ellipses can be both moved and resized.  

The border and filling style can also be changed. 
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Image Links 

Image links are links to other images in the currently open database.  

This is normally used to make a link to an image with higher magnification. 

 

Add an image link by: 

1. Click the Image Link icon, and place the hot spot at any position.  

2. Drag the image to associate with this point from a case to the link’s image box. 

 

Calibrated Ruler 

Click on the image to set the initial position of the scale bar. 

It can be moved and changed in size. 

Any calibrated length (that fits the image) can be used. 

It is also possible to set the style and color of the border and filling of the object. 

 

See Changing Color and Appearance for more information. 

 

Note: Delete an annotation by right-clicking the object and choose "Delete annotation".  

 

Note: All annotations in the current image are deleted by pressing the "Delete all" button, or by selecting "Delete all" in 
Image menu -> Overlay items… 

Changing Color and Appearance 

The color, line style, filling and other appearance properties of an annotation can be changed in the annotation’s property 
page.  

Open the property page by: 

• Double-clicking the annotation OR 

• Right-click the annotation and in the pop-up menu choose "properties". 

 

The z-order of the annotations can also be set.  

• Right-click the annotation.  

• In the pop-up menu, select Set as Top-most or Set as bottom-most. 
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Add-on Modules 

Add-on modules, Overview 
Picsara is highly modularized software. This has two major advantages: 

• Maximizing the ease-of-use, hiding features that are of no interest 

• Minimizing cost of investment and cost of ownership. 

 

The available add-on modules are: 

The Capture module: 

Adds support for both digital and analog cameras.  See The Capture module overview for more information. 

 

The Database module: 

This module adds support for organizing images, measurement and text into a searchable database. See The Database 
module overview for more information. 

 

The Database Administrator module: 

This module adds support for customizing the database. See The Database Administrator module overview for more 
information. 

 

The Analysis module: 

This module adds report and export functions of measurements, for example exports to Excel and to the Database. This 
module also adds some additional measurement tools. See The Analysis module overview for more information. 

 

The Object Analysis module: 

Adds support for automatic measurement of various features, such as object size and shape. See The Object analysis 
module overview for more information. 

 

The Hardness Measurements module: 

Adds support for manual measurement of Knoop and Vickers indents according to DIN and ASTM Standards. See The 
Hardness Measurements module overview for more information. 

 

The Grain Size Measurements module: 

Adds support for measuring grain size in steel, according to ASTM E-112 Standards. See The Grain Size Measurements 
module overview for more information. 

 

The Weld Measurements module: 
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Adds support for measuring key features of welded plates, according to DIN and de facto Standards. See The Weld 
Measurements module overview for more information. 

 

The Multi Focus module: 

Adds support for Multi Focus, which is a tool to create a depth focus image out of several images taken on a non-flat 
specimen. See The Multi Focus module overview for more information. 

 

The Montage module: 

Adds support for creating large montages of several partially overlapping images. See The Montage module overview for 
more information. 

The Capture Module 
The Capture Module, Overview 

External equipment like microscopes, hardness testers, or macro stands can be connected to Picsara. Configuring an 
input device is required for producing calibrated images as well as connecting video cameras and other image sources to 
Picsara. 

 

1. Select menu File-> System Preferences -> Input devices. 

• Up to 20 input devices can be added per computer.  

2. Properties and magnifications will be stored and when possible the related camera and accessories will be 
activated. 

• If connecting a video camera as the input device, the live image from the video camera will be displayed when 
selected.  

3. If using a Y/C camera (or S-VHS camera) use the Y-cable that comes with the original cable.  

• Connect the cable to Red & Green or Blue & Black. 

• Connect the cable so that one color matches (Green to Green or Blue to Blue). 

 

If the Capture module is present, the Camera toolbar can be enabled. If it’s not visible, select View -> Camera Toolbar.  

  

 

Note: Input devices that have been connected to and calibrated in an earlier version of Picsara do not need to be 
reconfigured. The previous configuration was saved on the computer. It is assumed however that the user who 
made the configuration had administrator rights. 

Adding an Input Device 

In Picsara, all optical equipment is represented by an input device. Up to 20 input devices can be connected to the 
computer and each input device can have its own configuration and unique settings.  
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When an input device is selected, the input device configuration is loaded and its attached camera is activated.  

 

To add a new input device: 

1. File -> System Preferences...  

2. Select the Input devices tab. 

3. Click Add, the Select Input device dialog box will open. 

  

4. Select the type of input device that best represents the connected optical equipment, and click Next: 

• Microscope or other calibrateable stand. Both lens and zoom level can be added. Zoom level is not required 
but a lens magnification must be added.  

• Microscope with objective positioning reader. Both lens and zoom level can be added. The microscope is 
equipped with a bar code reader to automatically identify which lens is being used. Please read How to 
configure an Objective Reader for more information. 

• Manual hardness tester. Both lens and zoom level can be added.  

• Macro stand. Used with a camera or a video camera mounted on a stand and identifies the different distances 
(different heights).  

• Endoscope. Used with un-calibrated endoscopes 

• Calibrated device. Identifies different magnifications. 

• Hand held camera. Used for free-hand photos. Images are not calibrated. 

• Un-calibrated device. Used for other devices that cannot be calibrated.  

5. Name the device.  

• Use names that clearly explain the input device, for example: Olympus BX51  

• Select the connection method for the camera cable. 

6. Select the camera connected to the input device.  
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• The list of cameras displays available cameras and frame grabber ports 

• If the connected camera is not in the list, check that the camera is on and working. 

• Only cameras active when launching the application are seen in the list. If a device or camera is physically 
connected after Picsara is started, the application needs to be restarted. 

Capturing Images from a Video Camera 

Picsara supports live video from the camera, given that the camera supports live video. Typical devices that support live 
video are: 

• Analog video cameras connected through a frame grabber. 

• DV cameras, FireWire cameras such as Digital Camcorders and Digital converters that supports DV 

• DirectShow compatible video cameras 

• DeltaPix DP200 and InfinityX cameras 

• Canon PowerShot and compatible still image cameras (Only preview mode) 

 

 

Some imaging functions can be executed using live video, but most functions must be performed on a frozen image. If an 
imaging function requires frozen image (such as save image for example), and the image is live, Picsara will automatically 
freeze or take a snapshot of the image. 

To Freeze the image: 

1. Select the current Magnification, see Setting the Current Input Device and Magnification  

2. Click the Freeze icon in the camera toolbar, or 

3. Select Video->Freeze image, or 

4. Click F6, or 

5. Click Space, or. 

6. Use an external pedal.  

• An external pedal can be configured in the File ->System preferences ->General systems tab. Please read 
Configuring an External Pedal for more information 

 

The Status Bar will display the current status (freeze or unfreeze).  

Note: If performing an action that requires a frozen image (such as saving an image to a file or database), Picsara will 
automatically freeze the image. However, for best image quality, manually freeze the image before beginning 
the operation. 

Setting the Current Input Device and Magnification 

When adding an input device, (see Adding an input device), it is possible to add magnifications (or focal distances) to the 
input device. A magnification list that corresponds to the available magnifications should be created. (It is also possible to 
add the magnification list after the input device is added. In this case, edit the input device in the System preferences 
dialog). 

 

To set the current input device and magnification: 
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1. Select a device from the Input device menu or from the Input device field in the Status Bar. 

2. Select a magnification from the Input device menu -> Set magnification, or from the Magnification field in 
the Status Bar.  

 

Calibrating an Input Device 

Most types of input devices can be calibrated in Picsara. It means calibrating the main lenses/objectives and possibly 
different zoom positions etc. After calibration, any combination of magnification and zoom can be used in order to produce 
correctly calibrated images. 

Before measurements can begin, Picsara must be calibrated. For some input devices, it is possible to measure on live 
images and for others the image must be frozen.  

Calibrations are stored with the associated input device and magnification.  

Before beginning to calibrate, an input device must be added (see Adding an input device) that is equivalent to the 
external device. For example: 

• Microscope with a video camera connected through a frame grabber. 

• Microscope with a digital camera. 

• Macro stand. 

• Hand held camera. 

Note: All calibrations made for a device will be automatically saved (also note that in order to save calibrations 
between launches of Picsara, the user who calibrates must have administrator rights on the computer).  

All optical systems have a certain degree of aberration. This means that magnifications are not exactly the same in the 
middle of an image as in the corners. It is therefore best to calibrate and measure in the middle of an image. 

Select a known reference object and let it fill as much of the image as possible. 

See to that the input device uses the same settings as normal working conditions.  

Find the best focus on the known reference object. 

 

Note: The process is the same for a digital high-resolution camera or analog camera connected with a frame grabber. 

 

Calibrate an input device: 

1. Add a microscope or another calibrated device configured with the appropriate magnifications. 

• Make sure the device is connected to a camera under the tab Input devices in the System Preferences dialog 
box. 

2. Activate the input device and select the magnification to calibrate.  

• Select the current device and magnification/focal distance to work with. Verify that the electronic magnification 
corresponds to the actual magnification on the physical input. If using zoom equipment, select the first zoom 
position on the list.  

• This can be made from the menu Input device or from the Status Bar. 

3. Capture an image with a known reference line (scale line, a ruler, or any other object with a known length).  
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4. In the menu Input device select Calibrate current magnification.  

5. Align the calibration tool with the known reference object.  

6. Make the line as long as possible to minimize measurement errors.  

7. In the Calibrate Magnification dialog box, enter the length of the line.  

  

8. Repeat the procedure for the remaining magnifications/focal distances. When finished, verify all the 
magnifications/focal distances to check for errors.  

9. Select a magnification/focal distance and measure the known line using the length or parallel tool. 

10. If using a zoom position, select an arbitrary magnification/focal distance and calibrate all the zoom positions. 
Observe that when calibrating zoom positions for a certain magnification/focal distance, all zoom positions for the 
remaining magnifications/focal distances are automatically updated. 

Capturing High-resolution images 

Picsara supports the capture of high-resolution images from devices that support Hi-res capture. Typical devices with 
high-res capture capability include: 

• Canon PowerShot still image cameras (also supports live video) 

• Canon SLR cameras, such a Canon D20 (do not support live video) 

• DeltaPix, InfinityX video camera (Both live and high-res mode, still image supports up to 21 Mpixels) 

 

To Capture a High-resolution image: 

1. Select the current Magnification, see Setting the Current Input Device and Magnification  

2. Click the High-res snap icon in the camera toolbar, or 

3. Select Video->Take a High-res snapshot, or 

4. Use an external pedal.  
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• An external pedal can be configured in the File ->System preferences ->General systems tab. Please read 
Configuring an External Pedal for more information. 

 

 

Capturing images using TWAIN 

Imaging devices such as scanners, consumer digital cameras etc that support TWAIN, can be used to import images 
directly into Picsara.  

 

In the case your camera supports both TWAIN and DirectX, It is strongly recommended to access it using the DirectX 
interface rather than using it as a TWAIN camera. See "Adding an input device" for more information. 

Before using a particular device via TWAIN, it is necessary to install the corresponding TWAIN drivers for that device. 
Consult the manual of the TWAIN device for instructions on how to do this. 

 

To capture images from a TWAIN source: 

 

1. Select File → Set TWAIN source... 

2. In the dialog, select the appropriate TWAIN source and press "Select" 

3. Select File → Acquire from TWAIN... 

 

After Step 3, the TWAIN driver will open in a separate window. Its appearance is unique to each driver, but generally you 
will have a choice to "Open" or "Capture" an image. When doing this, the image will be imported into the main Window of 
Picsara.  

 

To capture additional images, simply repeat step 3. 

 

Also note: 

The TWAIN capture interface in Picsara has four settings, found under  

File →  System Preferences, on the General Settings tab: 

 

  

TWAIN settings: 
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Autoload last used Twain source  

When Picsara opens, the last used TWAIN source will be pre-selected, so that steps 1-2 do not need to be carried out. 

 

Save image in case automatically 

Saves images captured via TWAIN directly to an open case. 

 

Close TWAIN driver after acquire 

Saves you the effort of having to close the TWAIN driver after step 3. 

 

Always ask for magnification when an image is loaded 

Brings up a dialog that allows you to assign one of the magnifications of the current input device to the captured image. 

 

Adjusting the Camera 

Depending on the camera, different settings on the camera can be adjusted.  

 

To adjust the camera: 

1. Press the Adjust button in the Camera Toolbar. 

2. Select Adjust camera settings in the Video menu. 

 

DeltaPix & Luminera cameras 

Picsara supports native support for all DeltaPix and Luminera digital cameras. Native support indicates that specific 
software has been written to support all (or most) functions in the camera, why ease of use can by combined with the 
complete control of unique functions in the cameras. DeltaPix and Luminera cameras uses DirectShow technology, why 
most information in the Adjusting a DirectShow Camera is relevant. For more specific information, please read Adjusting a 
DeltaPix/Luminera camera.  

Picsara 8.9 supports camera driver DeltaPix 1.5.2. 

 

IDS uEye cameras 

Picsara also supports native support for all digital uEye cameras, from the IDS manufacture. Native support indicates that 
specific software has been written to support all (or most) functions in the camera, why ease of use can by combined with 
the complete control of unique functions in the cameras. uEye cameras uses DirectShow technology, why most 
information in the Adjusting a DirectShow Camera is relevant. For more specific information, please read Adjusting a uEye 
camera.  

 

Other DirectX/DirectShow devices 

For DirectX/DirectShow compatible cameras it is possible to adjust Exposure time, Gain, Brightness, White Balance and 
Hue, given that the connected driver supports adjusting these features. Also, Picsara supports setting most of these 
controls into "auto" mode, when the camera driver supports this. 

If a control is greyed out, this indicates that the driver does not support that setting.  
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For more information on how to adjust DirectShow compatible cameras, please read Adjusting a DirectShow Camera. 

 

Analog cameras connected through a Meteor-II/Std grabber 

Using an analog Composite or Y/C camera, it is possible to adjust Gain/Illumination, Offset/Contrast and Color. 

Color has no functionality when using a black and white camera. 

 

Analog cameras connected through a Meteor-II/MC grabber 

Using an analog RGB camera, it is possible to adjust Gain and Offset for each color channel separately. It is also possible 
to adjust the Gamma parameter. 

 

Adjusting a Canon PowerShot camera 

Using a Canon PowerShot or compatible camera, it is possible to adjust Exposure time, Aperture, White balance settings, 
Flash, DIN value and exposure compensation. 

 

 

Adjusting a DirectShow Camera 

Adjusting the camera 

For most DirectShow compatible cameras it is possible to adjust Exposure time, Brightness, Contrast, Saturation, 
Gamma, White Balance and Gain, given that the driver supports adjusting these features. Select Video->Adjust camera 
settings… to bring up the settings dialog. 

Picsara communicates with the camera driver to find out which controls are supported. If a control is greyed out, this 
indicates that the driver does not support that setting or function. Often an updated version of a driver can give you access 
to more functions, without changing the hardware. 

In many cameras, automatic features, such as automatic exposure time and automatic gain, are supported. If a control 
has an associated checkbox next to it, this indicates that the driver supports automatic control of that particular feature.  
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Camera settings general dialog  

 

Adjusting special functions on DirectShow cameras: 

On most DirectX/DirectShow compatible cameras, it is possible to adjust additional settings to the standardized functions 
mentioned above.  To adjust these native settings, in the Camera settings dialog, go to the Camera driver tab. The two 
buttons "Capture filter…" and "Capture pin…" will bring up the camera manufacture’s camera settings dialogs. Since 
Picsara has no control of the visual appearance and functionality of these dialogs, please consult your camera 
manufacture’s manual for more information. Also, changes made in these dialogs may not be remembered and may get in 
conflict with settings made in Picsara. 

In theory, features related to the chip/sensor are found under the "Capture filter…" dialog, while live processing features 
such as Brightness, Contrast, White balance etc are found in the "Capture pin…" dialog.  

 

Post processing 

Using DirectShow cameras it is possible to post-process the image, for instance adjusting the color or flipping the image. 
In Picsara there are two post-processing filters, namely a Look-up filter and a processing filter. In the chain of filters the 
camera filter appears first, then the Lookup filter and thereafter the processing filter. 

The camera filter actually captures the image, and most likely applies some kind of processing or camera control, such as 
setting exposure time or performing auto-white balance. The next filter, the Lookup filter can change the color and or 
contrast/brightness of the image, and are applied to the signal (image) produced by the camera. Finally the processing 
filter operates on the entire image, and might flip or apply over- and underexposure warning to the image. 

Since some camera manufactures add some post processing to the camera driver as well, some features might appear 
twice in the user interface. As a rule of thumb, it’s often better to adjust the signal/image as early as possible in the chain 
of filters, eg on the camera rather in a post-processing filter.  

The built in post processing filters are found in the tabs "Lookup table" and "Filters" in the adjust camera settings dialog. 

 

Lookup table: 

Technically, a lookup table converts one color or gray level, to another color. For instance this can be used to change the 
brightness and contrast of the image. It is also possible to change the brightness and contrast of the Red, Green and Blue 
channels individually, making it possible to adjust for poor white balance. Lock the colors by checking Lock Colors. 
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It is also possible to set the Gamma value of the image. A Gamma value higher than 1 emphasizes the darker parts of the 
image, while a value lower than 1 emphasizes the brighter parts of the image.  

 

  

Camera settings lookup dialog 

 

On many cameras, especially CMOS cameras, a Gamma value around 1.3 is a good starting point. But different 
specimen and different cameras might require completely different values. Normally Gamma should be in the range 
between 0.5 and 2. 

 

Processing Filters: 

In the Filters tab some additional filters are available: 
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Camera settings filter dialog 

 

In the Preview filter group: 

• Over and under exposure filter. Changes over-exposed pixels to red, and under-exposed pixels to blue. 

 

Preview filters are only active when the image is live and are turned off automatically when the image is frozen. 

 

In the Image filters group: 

• Flip horizontal. Flips the image on the vertical axis. Use this filter if the microscope or optical equipment flips the 
image on the Horizontal axis. This phenomenon is quite common on microscopes equipped with an ergonomic 
tube, and on some hardness testers. 

• Flip vertical. Flips the image on the horizontal axis. Use this filter if the microscope or optical equipment flips the 
image on the Vertical axis. 

• Black and White filter. Converts a color image into a black and white image.  

• Emboss filter. Embosses the edges of a sample. Can be used to detect scratches etc on a flat surface. 

 

Filters in the Image filter group are applied to both live and frozen images. 

 

Adjusting a DeltaPix or Luminera camera 

Picsara has native support for most digital cameras from the DeltaPix and Luminera manufacture, for instance DP200, 
DD450 and InfinityX. Native support means that the software has been specially written to support all (or most) functions 
in the camera, why ease of use can by combined with the complete control of unique functions in the cameras. DeltaPix 
cameras uses DirectShow technology, why most information in the Adjusting a DirectShow Camera above is relevant. 

The adjust camera dialog for the DelatPix and Luminera cameras looks like this: 
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where: 

Auto Exposure: Activates the auto exposure function in the camera. The function analyses the complete image, why it 
works good on images with relatively small differences in brightness. It’s activated, the AE-Adjust slider will adjust if you 
prefer a bright or dark auto-exposure reference level. 

Long exposure time: For dark or poorly illuminated samples (or florescent applications). On some models exposure time 
can be as high as 6 seconds. 

Eliminate flicker: With this function activated the camera exposure time can only be set to fixed fractions of the lamp 
frequency. (50 Hz in Europe, 60 Hz in America). This will efficiently remove interference with the lamb bulb. The preferred 
solution is to have a stabilized light source with Direct Current, which does not flicker. 

 

Exposure: Set the exposure time manually, only enabled if Auto exposure is disabled 

AE Adjust: See Auto Exposure above 

Gain: Increases the input signal, but at the same time also increases noise. If the image is to dark, it’s always 
recommended to increase exposure time first.  

 

Auto white: Enables the Auto white function. The function makes an analysis of the complete image to find a good white 
balance. If the image consists of a lot of colored areas, this might fool the algorithm. Use the manual white balance or the 
hot-spot white balance function instead 

Red/Green/Blue: Manually adjusts the color settings. For an optimal image, it’s recommended that one of the sliders 
should be at 0. For instance, rather than increasing red and green, decrease blue. This gives the same effect. 

 

Adjusting a uEye Camera 

Picsara have native support for all digital uEye cameras from the IDS manufacture. Native support means that the 
software has been specially written to support all (or most) functions in the camera, why ease of use can by combined 
with the complete control of unique functions in the cameras. uEye cameras uses DirectShow technology, why most 
information in the Adjusting a DirectShow Camera above is relevant. 

The adjust camera dialog for the uEye camera looks like this: 
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Where: 

Exposure time: Exposure time can be set to "any" exposure time, with a much finer granularity compared to standard 
DirectShow cameras. This allows the user to set the exposure time exactly to the illumination circumstances, and to get a 
perfect exposure. It also allows the Auto-exposure to work to work with very fine granularity which makes it a lot easier to 
work with. 

The range of possible exposure times depends on the Pixel clock. The faster the clock, the shorter available exposure 
times.  

Pixel clock: The Pixel clock allows you to set the sensitivity of the camera. The slower the clock, the more sensitive 
(works better in dark conditions) is the camera. This can be useful in for instance fluorescence and dark-field applications. 
Observe that a low pixel clock will also affect the maximum refresh rate (speed) of the camera. Observe, the pixel clock 
can not be set when in auto-exposure mode. 

Gain: The analog gain on the camera. The default value should always be set to zero, but if the image becomes to dark it 
can be improved by increasing the gain. Do only use this function when exposure time can not be set to a higher value, 
since increasing the gain also increases the noise in the image. 

Brightness, Contrast and Gamma: Are pure post processing functions. The main usage for these settings are to 
"customize" the auto-exposure function and default response from the camera.  

Auto white (only color cameras): Activates the Auto-white function in the camera driver. The Auto-white function works 
on the complete image, and tries to automatically "find" a white spot found in the image, and white calibrate this spot. This 
more or less assumes that there are white areas in the image, or the auto white will fail. 

One Push (only color cameras): Runs the auto white functions for two seconds, then locks the settings. This is a very 
useful function in many transmitting light microscopy applications, where the specimen covers the compete frame of view. 
Move the specimen to a white/background area and press "One push". The camera is now calibrated against the current 
color temperature in the microscope. 
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Reset (only color cameras): Resets the color settings to default values. 

Red/Green/Blue (only color cameras): Allows you to manually control the white balance. Uncheck Auto white to enable 
the controls. 

 

Adjusting the White Balance in live image 

The white balance can be manually adjusted using either the camera setting functions or the LUT functions (in the post 
processing). Often a much easier way though, is to use the Auto White Hot-spot function. When in live video mode, simply 
click the White button in the Camera Toolbar, and click on a neutral spot in your image, for instance the at the background 
or in a white hole. This will adjust the post-processing look up table automatically.  

Note: Auto-white hot spot is only available for DirectShow compatible cameras. 

 

Configuring an External Pedal 

Using one or two external pedals can dramatically improve speed and ergonomics. The external pedal can be used to 
trigger commands such as freeze, unfreeze, and save to database/case. 

The pedal is suitable for demanding microscopy applications. The pedal is connected to a RS-232 port. If the computer 
does not have an RS-232 port, use an USB to RS-232 converter 

1. Select the File->System Preferences ->General settings tab. 

2. Check the box Enable in the settings for External button. 

 

Select the COM port that is connected to the pedal (or the COM port the USB to RS-232 adapter simulates). 

Select the command to be performed when using the pedal: 

• Toggle between live and frozen image. Toggles between a live and a frozen image. 

• Freeze image and save in case. Freezes the image and saves it to the current case. If no case or more than one 
case is open; the image only freezes. 

• Save image to case (without freezing). Takes a snapshot of the current image and saves the image to the 
current case. If no case or more than one case is open, nothing happens. 

• Take Hi-res snapshot. Takes a high-resolution snapshot of the current image. This requires that the currently 
selected camera supports high-resolution snapshots. 

• Take Hi-res snapshot and save in case. Takes a high-resolution snapshot of the current image and saves the 
image to the current case. If no case or more than one case is open; the image only freezes. 

• Take Hi-res snapshot and save in case and unfreeze. Takes a high-resolution snapshot of the current image 
and saves the image to the current case. After the image has been saved, the video toggles to live mode.  

 

Focus Aid 

With the Focus aid tool you can improve the focus of your image. The Aid magnifies the center of the live video, on a pixel 
by pixel basis. This in contrast with the magnifying glass for still images, which produces an interpolated zoom of the 
image. 

 

The Focus Aid is automatically turned of (temporarily) when the image is frozen. 

Note: Focus Aid is only available for DirectShow compatible cameras. 
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How to configure an Objective Reader 

An objective position reader communicates to  which objective on a microscope is currently in use. Since objectives often 
are calibrated in  this guarantees that the correct calibration is saved with images in the database. 
 

To configure an objective reader the user needs to have administrator rights on the computer. 

To set up: 

• Put objective bar code stickers onto each objective on the microscope. 

• Connect the objective reader to see that it works. A red light should shine. 

• Place a mounting kit with the objective reader mounted on it, onto the microscope. It should be placed carefully to 
ensure that the objective reader’s red light shines on the bar code stickers on the objectives. 

• Open System preferences and go to the Input devices tab. Add an input device and select the type of input device 
as "Microscope with objective positioning reader".  

• Select a name and the appropriate camera connection. 

• Select the COM port the objective reader is connected to. 

• Add magnifications. The magnifications must be added in the same order as the objective bar code stickers are 
put onto the objectives. 

• Add optical zoom factors if available. 

• Finish the setup and exit the system preferences dialog. 

• Verify that the magnification in the status bar is updated correctly when changing the objectives. 

• Calibrate the magnifications. See Calibrating an input device for more information. 

 

The Database Module 
The Database Module, Overview 

Picsara has been developed to organize large amounts of images and multimedia objects. Picsara can organize images 
for one or many users in one or several local databases, as well as connect to a central PictSure database where several 
hundreds or even thousands of users can share and organize large amounts of data. 

In order to access both local and centralized databases the Database module is needed. 

 

A cornerstone of the database is the case. The case typically represents a Study, a Project, an Incident or an 
Examination. The name case can be defined to any suitable term in the software, but in this manual we will use the word 
"Case". See Setting database system settings for more information. 

 

This is an example of a typical case: 
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The case consists of four pages: 

1. The text information page, that lists the text information for the case 

2. The image and documents page, which displays all images and documents in the case. 

3. The measurement results page, which lists all measurements for the case 

4. The system information page 

 

Furthermore, the database can be organized into several departments, each with its own unique design. This feature 
though, is not available for local Access based databases. 

 

The Text Information page 

The Text information page holds "Meta-data" common for all images, documents and measurement results in the case. 
For instance, if the case represents a Study, the text information page could have input fields such as Study Name, Detail, 
Operator, Due date, etc. Any user with administrator rights can freely design the layout and the input fields. The design is 
unique for each department.  

Input fields can be of different types, for instance: 

• Text input fields 

• Drop down controls 

• Yes/No Check boxes 

• Tree controls  
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Also, different properties can be set to the controls, such as: 

• A required value 

• Searching capability 

• Editing rights 

 

 

The Image & Documents page 

The Images and Documents Tab will display images and documents belonging to a case. Images are displayed as a 
thumbnail image. Other documents/files added to the case, will be shown with the associated applications icon. For 
instance an Excel document will be shown with the typical Excel icon. 

 

  

A case with the Image and documents page open 
 

There are several ways of adding an image or document to the case. 

1. Drag-and-drop the image from the main image window, into a blank space in the Image & Documents page. 

2. Add one or several files manually 

• Select Case -> Add files...  

• Select one or several images/documents to import into the case. 

3. Add files from the file explorer, using drag-and-drop. 
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In order to open an image or document, simply double click the thumbnail/icon: 

• In the case of an image, the full size image will open in the Picsara main window. 

• In case of a file, the associated application will be launched, and the file will be loaded into the application. 

 

The Results page 

The Results page holds measurements for the case. Results can be stored in the case with or without the associated 
image. If the image is stored though, a link between the measurement and the image is created. 

The Result tab can store any measurement result created with Picsara. 

If measurements have been cleared, their visibility can be restored by simply double-clicking on the listed measure(s). 

 

The System Information page 

The System Information page contains system information that is saved automatically to the system. 

  

The System Information Tab contains system information that cannot be edited by the user, for example information such 
as Case ID, Created By, Creation date etc. 

 

Creating a new Database 

Before starting to work with images in a database, a connection to an existing database, or a new database, needs to be 
established. First select an Access compatible database or a Microsoft SQL based database. 

1. Access based database: 

• Simple file based database 
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• Provides no login security 

• Easy to create and backup. 

2. SQL based database: 

• A high performance database 

• Provides strong login security 

• Requires any of the MS SQL databases to be installed, such as MSDE or MS SQL Enterprise. 

  

It is possible to create any number of databases, using a predefined layout. 

Layouts for the following labs/applications exist: 

• Failure analysis 

• Heat treat 

• Production 

• Research 

 

To create a new database: 

1. All open databases must be closed before creating a new one. 

2. Select Database -> Administrate database -> Create new database...  

• The Create Database Wizard will open. 

3. The Select database type dialog box will request what database type to create. 

Select between two types of databases. 

• Microsoft Access database:  Select this database to create a local database for personal use.  Microsoft 
Access does not need to be installed on the computer for this type of database.  
 
The Microsoft Access database provides an inexpensive way to store and organize data but has limited functions 
for data and operation security. 

The Access database is saved as a file. The user must provide a filename and a location for that file. A 
Connection string name and an ODBC DNS name must also be supplied. 

Next enter the name of the default user. Access databases do not support passwords. 

• Microsoft SQL Server database:  Select this database to create a local or a central SQL database.  
 
Microsoft SQL Server database provides better protection and operation security but requires a variant of 
Microsoft SQL (ex: MSDE, SQL 7 or SQL 200) and an account on an SQL database to create an SQL database. 

In order to complete the creation, supply a database location (to an existing SQL server), a database name (the 
name of the database in the MS SQL database) and an account with system administrator rights. 

The name and login of the default user should also be supplied. 

 

A PictSure database cannot be created through either Microsoft Access or Microsoft SQL Server databases. A PictSure 
database requires PictSure database components. 
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3. Finally, select the type of template (or create a blank database) 

Managing Connections to Databases 

A connection is a description of where to find a physical database. Before opening a database, a Connection to the 
database must be created. Up to 20 connections can be configured simultaneously on each computer. All connections are 
valid for all users on the machine. 

Only a user with administrator rights on a computer can change the connections on it. 

Select File/System preferences…/Database connections for a list of configured connections on your machine. By default, 
any databases created within the software will be listed here. 

 

Create a new connection by pressing Add new…  

There are two types of connections that can be created, namely: 

• A connection towards an ODBC compatible database, normally a local Access database. See below for more 
information. 

• A connection towards a PictSure database, normally a centralized database, based on MS SQL technology. See 
below for more information. 

 

Select the type of database you would like to configure, also give the connection a name that explains the data source. 

 

ODBC compatible databases 

Before an ODBC connection in Picsara can be made, an ODBC connection must be configured in Start -> All Programs -> 
Control Panel -> Administrative tools -> Data Sources (ODBC) -> System DNS. The list in System DSN includes all 
current ODBC connections on the computer. 

Note: Please observe the difference between a PictSure connection (often named "connection" in this document) and 
an ODBC connection (always named ODBC connection in this document). A PictSure connection can point to 
an ODBC connection, which in turn points to the physical database. 

 

Note:  ODBC is a standardized protocol used to communicate with databases. Initially Microsoft created ODBC, but 
today most database engines support ODBC. The idea is to hide the physical database, and allow Picsara to 
talk to virtually any database engine, using the same set of instructions. Although in theory Picsara can talk to 
any database engine, in reality there are some variances among the different databases. There is no guarantee 
that any database engine work. Currently Jet/Access databases and MS SQL databases are successfully 
verified to work with Picsara. 

 

Note: By default, if running the complete installation, the installation software copies a demo access database to your 
C:\program files\Bildanalyssystem\Picsara881\Databases folder. It also creates an ODBC connection called 
"Demo database 8.9". Finally it creates a PictSure connection called "Demo database 8.9" to the ODBC 
connection "Demo database 8.9". 

PictSure compatible databases 

A PictSure database is a database that "speaks" the native "PictSure" language/protocol. This language is optimized for 
saving and retrieving large objects. 

In order to connect to a PictSure server, the physical address of the server (and the port, if it does not use the default port) 
must be known. Ask your system administrator for this information. 

Note: A PictSure server is normally a centralized large-scale database, based on a MS SQL server. In order to 
connect to the server, you will also need a login and a password. 
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Opening a Database 

Before opening a database, make sure that there is a connection to the database. Please read Managing Connections to 
Databases for more information. 

 

To open a database: 

1. Select Database -> Open database...  

• If a database is already open, the menu selection Open database... is unavailable. Use the Close menu to close 
the current database, and the open database menu selection will appear.  

2. After selecting a database, the Login prompt will appear. Select the database and enter a name and password. 

  

The Picsara caption bar will be display the name of the open database, current department and current user. 

Note: The default login for the demo database is "psAdmin" without a password. 

 

Note: When launching the application, the user will automatically be prompted to open the last used database. 

 

Note: When logging in to a PictSure database, the Home Department will open automatically. 

Upgrading an old Database 

Databases from version 8.6, 8.7 and 8.8 version software can be upgraded directly. Before upgrading a database, it is 
strongly recommended to make a backup of the database first. This will provide a way to return to an older version of the 
software, if needed. There is no way to convert an 8.9 database to an older format. 

To upgrade a database: 

1. Close any open databases. 

2. Select Database -> Administrate database -> Upgrade old database. 

3. Login to the database that needs to be upgraded 

 

Note: The login user must have administrator user rights. 

 

Selecting the Current Department 

A Department is a logical space isolated from other departments in the database. A user can have access to one or 
several departments. The database can have any number of departments. 
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Note:  Multiple departments are only supported for a PictSure server. When using a local Access database, there is 
only the "default" department. 

When logging in to a PictSure database the home department will automatically become active. The active department is 
the department where new cases will be created, and where normal searches are performed. Please observe that even if 
only one department is active, searches in all departments are possible. 

 

To change current department: 

1. Select Database -> Change department... 

2. A list of available departments will appear. Only the departments that the user has access to will appear in the list.  

Creating new Cases 

To create a new case for storing images and/or results: 

1. Select Database -> New case… or, 

2. Click the "New case" button in the database toolbar. 

A new empty Case will appear. The case will always be created in the current department. 

Before the case can be closed, all input fields that are of type "must have a value" (marked with a star), must be 
completed.  

 

 

A case with the text information page opened 

 

It is possible to delete a case, regardless if all input fields have a value or not. Locked case cannot be deleted. Select 
Case->Delete case to delete the current case.  
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Note: Any number of cases can be opened simultaneously. 

 

Note: If logged in to a PictSure database, the logged-in user must have an account with permission to create new 
cases. 

Searching for cases 

To search for one or several cases in the current department: 

1. Select Database -> Search case... or, 

• Click the "Search case" button in the database toolbar. 

• The Search case dialog box will open. On the first page, all searchable input fields will be displayed. On the 
second page, system fields will be displayed.   

2. Enter search criterions in the available fields and click the Search button. The search criteria differ depending on 
the input type.  If no criteria are entered, all of the cases will be listed. 

3. The Search Result dialog box will open with the search results. (It is possible to save the search results, see tip 
below). 

  

4. Select one or several rows and click the Open button. The selected cases will open. 

• Use Shift + mouse click to select adjacent cases. 

• Use Ctrl + mouse click to select non-adjacent cases. 

 

To search for one or several cases in all departments: 

1. Select Database -> Search case in all departments 

• The Search case dialog box will open. On the first page, all searchable input fields that are common in all 
departments will be displayed. On the second page system fields will be displayed.   

2. Continue as above for search case in current department. 
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Keep the search dialog open, after you have opened one or several cases, by unchecking the "Close result at selection" 
check box in the search case dialog. 

Tip: In a search result list, it is possible to save the search by selecting "save search". Type a name for the search 
and click OK. To repeat the search later, select the Database menu and the desired search. Up to 20 custom 
search filters can be saved. 

 

Searching for Images 

To search for one or several images in the current department: 

1. Select Database -> Search image... or click the "Search image" button in the database toolbar. 

• The Search image dialog box will open. On the first page, all searchable input fields for case fields will be 
displayed. On the second page, all searchable input fields for image fields will be displayed. On the third page, 
system fields will be displayed.   

2. Enter search criterions in the available fields and click the Search button. The search criterions differ depending on 
the input type. If no criteria are entered, the first 100 images will be posted. 

3. The Search Result dialog box will open with the search results. 

 

4. Select an image, right-click and choose Open. 

• Open – will open the image in the window 

• Open case – will open the associated case 

 

To search for one or several images in all departments: 

1. Select Database -> Search image in all departments 

• The Search image dialog box will open. On the first page, all searchable input fields that are common in all 
departments will be displayed. On the second page system fields will be displayed.   

2. Continue as above for search image in current department. 
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Adding and Deleting Images 

There are several ways of adding images to any open case: 

1. Simply drag-and-drop the image from the main window to the case (the image & document page must be active) 

• If the image is calibrated, the calibrations will be saved together with the image in the database. 

2. In the Case menu, select Add Files… 

3. Drag-and-drop images directly from the File explorer. 

 

 

To delete images or documents from a case: 

1. The case must first be open.  

2. Right click on the thumbnail of the image or file to delete. 

3. Select Delete from the pop-up menu. 

• Images cannot be deleted from a locked case. 

Note: If images with annotations are saved to the database, the annotations are saved separately from the image. 
When the image is re-opened later the annotation are restored.  The annotations can still be edited as well. 

Adding and Deleting Documents and other Files 

It is possible to add documents, for example Word and Excel documents, to a case. Many file types are supported and 
can be opened from the case as long as the current computer supports the format. 

 

There are several ways to add a file to an open case: 

• Select "Add files.." from the Case menu in a case. 

• Drag-and-drop files directly from the File explorer to a case. 

 

To delete files from an open case: 

• Right-click on the file thumbnail in a case and select "Delete". 

• Mark the file thumbnail in a case and select "Delete.." from the Edit menu. 
 

Observe that a file cannot be added or deleted in a locked/signed case, (see Locking a case). 

 

Saving Measurements to a Case 

It is possible to save measurement results to a case. The results in a case are displayed in the same fashion as the 
results in the Result window. In addition these results will be stored and linked to other information in the case. Data in the 
case can also be included in an MS Word report. Double-clicking on the listed measure(s) will open the stored image with 
the measures displayed. 

 

In order to be able to save results to a database case, the Analysis module must be activated. Please see Add-on 
modules for more information. 
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To save measurement results to a case, simply open a case and keep it open while performing measurements. The 
results will be saved to that case automatically. 

 

Alternatively, drag an image that contains measurements into a case. Both the image and the measurements on the 
image will be saved. 

 

  

The result tab of a case. 

 

Tip: It is possible to rename measurements for reporting purposes. Mark a measure in the result list, right-click and 
select "Edit name..." from the popup menu. 

 

Tip: The MS Word reports created by Picsara can be made to execute Visual Basic (VB) macros. This is a useful 
way of performing specific calculations based on measurement results. For instance, a VB macro could be used 
to calculate the mean area of three measurements and to print the result on a certain row in the report. See 
Technical notes, Creating Report Templates using Microsoft Word. 

Adding Audio Dictates to Case and Images 

It is possible to record sounds, comments or dictates together with each case and even with each individual image 
within a case. Use this feature to add for example comments, notes and instructions to other users, which are easier to 
give in speech than in writing. 

 

The maximum length of the audio annotations depends on the compression of the sound codec used by the computer, but 
generally about 60 seconds can be recorded.  

 

The audio controls are made up of four buttons: Play, Record, Pause and Stop. Pause can be used both during recording 
and during playback. Stop is used to end a playback or to stop (and save) a recording. 

 

The audio controls for the case are shown in the case toolbar. 

 

  

Case toolbar, with audio controls in the right part 
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The audio controls for images are shown at the bottom of each image thumbnail. Select whenever to hide or show them 
by using the case menu, under View->Show audio controls under thumbnails. 

 

  

Thumbnail image in a case, with audio controls below the image 

Tip: Please be aware that audio annotations are always saved internally in the database. A long annotation may use 
up to 8 MB of storage. The maximum file size of MS Access databases is limited to 1 GB, and a MSDE 
database may hold up to 2 GB. Using long audio annotations extensively may cause the database to reach the 
maximum size more quickly. 

Locking a Case 

Information in a case (text, images, documents and results) can be locked. This will prevent information from being 
changed or manipulated.  

• The Lock function can also be thought of as a signing or a certification of a case.  

• When a case is locked, images, data and documents cannot be added, deleted, or changed. 

 

To lock a case: 

1. Click the Lock icon in the Case Window, or select Case\Digitally sign case. 

2. Enter password.  

3. Click OK. 

 

There is the possibility to set if signing a case requires a password or not. This setting is made in Database  
Administrate database  Database settings  "Password required when signing case".  

A copy of a locked case can be created. Changes to the copy can be made without affecting the original case. When 
searching for a case, only the last copy will be displayed in the search result list.  

 

When a copied case is opened, the caption bar of the case will display that it is a copy. To open the original case: 

1. Select the System information tab. 

2. Click the Open button next to the Reference to field. 

 

To make a copy of a locked case: 

1. Click the Lock icon in the Case Window. A prompt will appear asking if you want to create a copy of the case. 
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• This will create a copy of all the images and data in the case. 

• The copy will be "unlocked". Allowing the user to add and change information. 

Note: There is no limit on the number of copies that can be made. 

Creating Customized Word Reports from a Case 

Customized reports can be created from a case, including images, text information and measurement results. A report is 
created using Microsoft Word. 

A report is always created from a report template, and the template is populated with information from the case. A default 
report, that matches the current database design, can be created from within Picsara. Please read Creating Customized 
Word Templates for more information on creating new templates. 

To create a report: 

1. Open the case to create a report from. 

2. Select Case -> Create Word report...  

3. Select the template the report is to be based on.  

4. Microsoft Word will open the selected template and add text, results and images to the document. 

5. Manually edit the document to create a customized report.  

 

  

Word report example 
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Creating Customized Word Templates 

All reports created from a case are based on a template. It is possible to create a template from an empty document in 
Word, but using the Report template generator wizard is normally much easier.  

To create a template that matches the currently open database and department: 

1. Select Database->Create report template… 

2. Enter the settings: 

• Document Title and logo will appear across the top of the first page of the document 

• Number of images is the total number of images to added each time a report is created 

• Number of measures is the number of placeholders for measures of the same kind.  For example, a value of 1 
would allow for one measure of each type: length, radius, grain size, etc. A value of 3 would accommodate a 
total of three measures of each type. 

3. Enter the template name, and save it in a suitable location. 

4. The template is now opened by Word. From within Word, it is possible to customize the template to fit desired 
needs. For more information on how to create templates for Picsara, please read Creating report templates using 
Microsoft Word. 

5. Don’t forget to save the template after modifying it! 

Saving a Case as a File 

It is possible to save a complete case, together with both text information and images, into a set of files. This will enable 
the user to save a case to a CD or Memory Stick. The result can be viewed with any web browser such as Internet 
Explorer. 

To export a case as a file: 

1. Open the case to save 

2. Select Case -> Save as web page... 

• The case will be saved as a group of files, consisting of one HTML file, and one JPEG image file per image in 
the case. By opening the HTML file in a Web browser the case information and the images can be viewed 
together. 

• Double-clicking on an image in the browser will open the image represented by the thumbnail. 

• Only burned in measurements or annotations will be visible 
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Example of a saved case 

Note: It is possible to move the group of files to another folder or device (such as memory stick). To facilitate this, it is 
recommended to save each case in a new empty folder. 

Sending a Case as an E-mail 

Sending a complete case, together with text and image information can easily be done. The receiving party can read the 
e-mail in a standard e-mail client, such as Outlook. 

Sent cases will appear in the outbox in the standard e-mail client on the current computer. Therefore, it is required that 
there is an e-mail client installed and correctly configured for sending e-mails on the current computer. In theory, any 
MAPI compatible e-mail client can be used, such as Outlook, Outlook Express or Lotus Notes. For more information, 
please contact your vendor. 

To send a case: 

1. Open the case you want to send. 

2. Select Case -> Send as email... or click the Envelope button. 

• The e-mail client will open. 

• The text in the case field that is the field which is "visible in the system menu", will be copied to the e-mail 
subject. 

• The text information will be copied to the message body. 

• The images will be attached to the e-mail as jpeg images. 

3. Type or select a receiver address and send the e-mail. 

Note: An e-mail program must be installed and configured before using the e-mail option. The e-mail program must be 
MAPI compatible to work with Picsara. 
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Note: If logged in to a PictSure database the user must have an account with privileges to e-mail a case. 

 

Using a Barcode Scanner to add data into a Case 

A barcode scanner can be used to scan data such as sample numbers, CustomerID etc. This requires the data to be 
available in a barcode format. For instance, assume that the samples have a bar code label, indicating the sample 
number ID, attached to it. When scanning the bar code, a new case is created; the SampleID input field is filled with the 
sample number ID and the Image page is displayed. 

To activate the bar code scanner function: 

1. Select File->System Preferences ->Barcode reader tab 

2. Activate the Barcode reader checkbox, to enable the barcode reader. 

 

  

An example of a document with a Sample ID in both human readable format as well as a barcode 
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Barcode reader settings in System settings 

 

3. Enter the name of an input field where the scanned buffer is to be copied. 

4. Select the termination character the scanner is using. The termination character is set up in the bar code scanner 
configuration software and needs to match the selected character in Picsara. 

Note: If the bar code includes tab characters, multiple input fields can be scanned at once. For instance the bar code 
can include SampleID, CustomerID and CustomerName, if the input data is <TAB> separated. When doing the 
configuration of the bar code reader, type the case input field where the first string of the bar code should be 
inputted. Then the next string will appear in the following case input field (depending on the tab order for the 
case fields). 

 

Note: Most bar code formats can only store digits but a few can store both text strings and data. 

How to create a new case using the bar code scanner:  

1. Make sure the Picsara main window is the active window. 

2. Scan the bar code to create a new case. 
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Example of a newly created case by the use of a barcode reader 

Note: If another application, dialog, or a case is active the barcode will be controlled by the active application, dialog, 
or case. This can be useful when searching for a case using the barcode reader. 

 

Working in a Multi-User environment 

In a multi-user environment, it is vital to be able to assign different sets of permissions to different users. When connected 
to a PictSure server, Picsara supports a user rights management system. This system assigns each user to one or more 
departments, and also assigns each user a role. The role determines what permissions the user has in the database.  

 

When connected to a PictSure server, Picsara also keeps track, if two users are trying to modify the same case at the 
same time, and efficiently prohibits this. The second user to open an already opened case will receive a warning, and can 
open the case in read-only mode. 

 

As an end-user of Picsara, working in a multi-user database, you will primarily notice the following effects: 

 

• Each user has to login to the database providing both a user name and password. An account may be disabled by 
the database administrator. 

• Each user has a home department, and possibly also has access to other departments 

• Some actions, such as modifying the database system settings, signing cases etc may not be available, even if the 
database administrator module is installed. 

 

The following actions may be restricted if the user lacks permissions: 

 

• Modifying the database system settings 

• Signing a case 
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• Creating a case 

• Unlocking a case 

• Edit the text information in a case 

• Adding, deleting or modifying files, images or image information in a case 

• Saving the case as HTML or creating Word reports from a case 

• Saving audio annotations to cases or images in a case 

• Playing audio annotations for cases or images in a case 

• Adding or deleting measurements from a case 

 

Please note that the PictSure server rights system is distinct from rights given to the Windows user account. The PictSure 
server right system only applies to actions within the PictSure database. 

 

For example, features such as calibration of the input device may require the user to be logged in on the computer with 
Administrator rights.  

Looking up data in an External Database 

It is possible to lookup data in an external database. Typical applications are: 

• Looking up a patients name and address, given that the social security number is typed in.  

• Looking up a customer name and due date, given that the Sample ID is typed in. 

 

If the function is enabled, press the "synchronize button" and the corresponding fields will be updated with data from the 
external database. 

 

In order to enable and configure this function, the Database Admin Module must be installed. Please read How to 
configure external lookup functionality for more info. 

Note:  The synchronize button is only visible if the external lookup function is enabled. 

The Database Administrator Module 
The Database Administrator Module, Overview 

Any Picsara database can be modified and designed to suit the user’s needs. For instance it is possible to add any 
number of input fields, and set the controls position and size. 

The Database Administrator Module requires the Database module. 

 

The Database Wizard dialog box will appear when operating Picsara for the first time. 

1. Select the option Create a new empty database. Follow the wizard commands to create a new database. 
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Database wizard 

Note: If the Database Wizard dialog box does not appear, select Create a new database from the Database -> 
Administrate database menu. 

 

Customizing the Case design 

When changing a case or an image data field, make sure the correct department has been selected and is active. 

1. Select Database -> Administrate database -> Modify database... 

2. The Modify database design dialog will open. 

Double-click on one of the fields in the available list and change the properties for the selected field. 
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Case field properties 

 

• Name – the control name can be modified. However, it is necessary to update templates which include that field. 

• Visible:   The field is visible for both searching and presentation. 

• Must have a value:   The user cannot close or lock the case if this field is empty.  

• Visible in system menu:  Indicates that the field contains important data, such as Order # or Sample ID. It will be 
displayed in the title bar of the case. 

• Enabled:  If not checked, the field is visible but cannot be edited.  

• Global: When checked, this input field is shared with all other departments (see PictSure server for more info on 
departments) 

• Visible in search:  Makes it is possible to search the field.  
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• Only exact search:  Restricts wide searches. 

• Tab-order Position:  Enables the selection and order of fields when the Tab key is pressed.  

• External query:  To look up data in an external database, in order to populate fields with data from another 
source, into the case. Please read Looking up data in an External database for more information. 

 

Adding New Fields 

Text fields belonging to all cases within a department can be customized. 

To design a case or an image field: 

1. Make sure the correct department has been selected. 

2. Select the menu Database -> Administrate database -> Modify database... 
 

  

Modify database settings dialog 
 

3. The Modify database design dialog box will open. 

• Case Tab:  Displays existing fields and field properties for the case. 

• Image Fields Tab:  Displays existing fields and field properties for case images. 

4. Click the Design Case or Image Fields button. The Design dialog box will appear 

5. To add a new field, click the Add button. The Select Input Type dialog box will appear. 

6. Select the type of field to add. 
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Case field input types dialog 

 

Single line free text:  Common text, for example ID number, order number, customer, etc.  

Multiple lines, free text:  Long text, for example comments or descriptions.  

Number:  Integer or float.  

Date:  Date is entered in local format but can be displayed in different formats. 

Predefined text:  Creates a list of options. 

Predefined or free text:  Creates a list of options or the user can enter text. 

Yes/No:  Creates a Yes/No check box.  

Tree:  Creates a field that organizes its contents in a tree-like structure. 

7. Check the Control must have a value option to create a value required field for a selected field type. 

8. Click Next. 

9. Enter a name. 

• If a pre-defined field is selected, enter a list of options. 

• Cases can have different designs for different departments. If a field exists for another department,  it will have 
the same length as in the other departments. 

 

Setting database system settings 

Set database settings in the Database system settings dialog, opened from the Database menu -> Administrate database 
-> Database settings. 

 

Note:  To set database settings the user must have administrator rights. 
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Database ID 

To be able to keep track of the current database instance it is possible to set a unique ID for the database. 

 

Logging level 

It is possible to log: 

• Errors only 

• Errors and system changes 

• Errors, system changes and user actions 

 

The logging is saved in the database’s log table, (which is opened directly from the database, not from Picsara ). 

 

Case meaning 

The name case can be defined to any suitable term in the software such as Project or Study (in this manual the name 
"case" will still remain). The database will be updated to use this term. The short name will be used for the icon. 

 

Storage 

Picsara can store images (compressed or uncompressed) both in the database and as individual files outside of the 
database How to store images (compressed or uncompressed) is often determined by storage space, network speed and 
image quality requirements. 

 

Advantages of saving images and documents to a local (internal) database are: 

• All information is stored in the same place. 

• The database is easy to backup and it is easy to administer security. 

• All information is kept intact when moving the database. 

However, local databases can grow fast creating longer access and backup times. 

 

Advantages of saving images and documents to a server (external) database are: 

• Creates a system with better scalability and faster access times. 

However, the administration of user rights and access security can become challenging.  
 

Smaller local databases have a limited amount of data (documents and images) that can be stored. Microsoft Access can 
hold up to 1 GB, this is equivalent to about 1000 uncompressed images or 10,000 compressed images. 

Larger server databases can store much larger amount of data. Microsoft MSDE can take up to 2 GB. Microsoft SQL does 
not have any limits on how much to store. 
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Compression ratio 

Compressed images are saved as JPEGs. A database administrator can adjust the grade of quality of the compression. It 
is recommended to save images compressed with a Q-factor (image quality) around 70. 

 

How to configure External Lookup functionality 

It is possible to query and retrieve data from an external database. Typically this is used to lookup Client or Sample 
information, given that the user knows Client ID or Sample ID. It can also be used to calculate data or verify that data is on 
a given format. 

 

The lookup mechanism is always provided through a customized lookup DLL, which can be developed by any customer.  

 

In order to enable a custom lookup DLL: 

1. Open the Image Database 

2. Select Database ->Administrate database-> Modify database… 

3. Double-click on the Control/Field name that holds the data to be looked up, typically Client ID or Sample 
ID. 

4. In the External Query section, press Configure… 

5. Type in the Lookup module DLL name (with path) and custom parameters. 

• By default, all field names and field data is sent to the lookup DLL when the user presses the 
sync button. The extra parameters can be used to pass additional information such as user 
name and password to the lookup DLL. 

 

Please read the Technical note: How to develop a Lookup DLL for more information 

The Analysis Module 
The Analysis Module, Overview 

The Analysis Module extends Picsara, making it possible not only to take care of your analysis results, but also create 
stunning Reports using Excel. Alternatively you can export raw data to Excel, using it as your number crunching tool for 
statistical analysis or other types of analysis. Additionally, the module adds a few more interactive measurement tools to 
Picsara, such as the curve measurement tool, the count objects tool, the radius measurement tool, the polygon 
measurement tool and the angle measurement tool. 

 

One main feature with the Analysis module is the Result Window. The Result Window displays a list of numeric 
measurements. Also the report and export functions can be accessed from this window. 

Additionally to the above, if the database module is present, this module will allow you to store measurements in a 
database case. Even if the analysis module is not present, viewing already stored data (made from a computer with 
analysis module) is still possible. 

The Result Window 

The Results Window displays all the measurements that have been made. Data from the Result Window can be copied 
and pasted into other applications, such as Excel or a text file. 

To activate the Results Window: 
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1. Select View - > Measurement results window. 
Or click the Result button in the measurement toolbar. 
 

  

Result window 

 

Creating reports with Excel Manual Interactive Mode 

Excel Manual Interactive Mode will make Picsarainteract with Excel, helping in a very simple manner to create reports, 
preferably using existing Excel templates. This function has its beauty in its simplicity, and does not require any need off 
building advanced macros nor does it need any programming skills. Simply start the tool, activate a cell in your Excel 
template, and it will be populated with the next measurement performed in Picsara.  

Using this function, normally the screen is split in two parts, either horizontally or vertically, where one part is Omnimet 
and the other is Excel. It’s possible to start of with a blank Excel page, or use an existing template file that can be 
populated. For instance it can look like this: 

Activate the function by: 

 

1. Select Measurements->Excel Manual Interactive Mode, or press the Excel button in the Measurements toolbar 

2. If required, select the Excel template to use for the interactive mode. See Setup Excel Manual Interactive Mode for 
more information. 

3. In the Excel application, select the cell you want your first measurement result to be copied to. 

4. Make the measurement in Picsara 

5. Continue to make measurements until the report is complete. Manually select each cell in Excel if the "auto-move" 
rules do not apply. 

6. Exit the function by un-selecting Measurements->Excel Manual Interactive Mode, orrelease the Excel button in the 
Measurements toolbar 

 

For more information about how to change the default behavior of the function, please read how to change behavior for 
Excel Manual Interactive Mode below 

 

Example: 

 

The Printed Circuit Board example, found in C:\Program files\Bildanalyssystem\Picsara89\Templates\ Excel Interactive 
Measurement templates\PCB Template.XLT demonstrates a simple example where the user is supposed to measure 
some given features on a printed circuit board using various measurement tools. This simple example demonstrates a 
fail/pass scenario, as well as some statistical calculations.  
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For demonstration purposes, this template has three input fields suitable for manual data entry, such as Sample No, 
Detail and User (pink cells): Also in the template, all but the input cells are locked, preventing the user from overwriting 
text information in other cells. At the bottom of the template (in yellow), some simple calculations and tests are performed. 

Note: For best results, a high resolution monitor should be used with this function, preferably at least 19 inch at 
1600x1200 pixels. Depending on your camera resolution and your Excel template, lower resolutions can be 
used.  

Note: This function assumes that Microsoft Excel 2000 or later is installed. 

Note: The demo template can be used as a starting point for creating new more advanced templates. In more 
advanced "real life" applications, features such as saving results to third party database or creating advanced 
charts can be added. 

Setup Excel Manual Interactive Mode 

It’s possible to fine tune the behavior for the Excel Manual Interactive mode function.  

 

Setting the default Excel template: 

Select Measurements-> Setup Excel Manual Interactive Mode: 

In the template section, select the default template to use.  You can use any existing Excel template or a blank.  

It’s also possible to make the system request a template each time the function is activated. 

 

Note: A template file is a normal Excel document saved with the .xlt extension. A normal Excel spread sheet file (with 
the .xls extension) can also be used as a template. 

 

Window settings 

It’s possible to tile the Excel Window either horizontally or vertically. It’s also possible to have it free floating, but in most 
applications this might not be the best choice. 

 

Also you can set the relative size of the Excel window (relative to the Picsarawindow). Your preference might depend on 
the size of the image, screen resolution and Excel template) 

 

Setting auto move behavior 

Select Measurements-> Setup Excel Manual Interactive Mode: 

In the Auto move section, activate the function by selecting "Auto move to next cell after each measurement". Select if to 
move to the right or move down. 

 

Setting auto move behavior 

Select Measurements-> Setup Excel Manual Interactive Mode: 

In the Auto move section, activate the function by selecting "Auto move to next cell after each measurement". Select if to 
move to the right or move down. 
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Creating Excel reports from existing data 

As an alternative to using the Excel Manual interactive function, it is possible to create Excel reports based on already 
measured data. The Excel report function exports raw data to Excel, where it will be formatted into a proper layout. 

With this function it’s also possible to create or re-create a report on saved measurements in the database. 

The normal process is like this: 

1. Make the measurements in a given order, or open a case with saved data 

2. Select the Create report function, and select a template to export to  

 

• The raw data will be exported to a page called "RawData" in the Excel application 

• A macro that copies the "preferred" data into the report page will be executed. 

• The report page (normally the first page) will be displayed 

 

Please see the demo templates for a better understanding on how to create Excel Reports. 

 

Example 1, General Field Statistics report 

In this example the user wants to create a report on field statistics in a set of images. For instance, creating a report with  
the average diameter of all objects in each field of view. Also the report should include the average size and standard 
deviation of all objects in all fields. Objects in this case could be anything, such as carbon fibers in a composite material or 
blood cell sizes in a blood sample. 

 

1. Measure the objects using the distance tool in the first field of view. (between 1 and 11 objects per field can be 
measured in this report) 

2. Unfreeze/Freeze (or load a new image). This is an important step in this example. Since this report calculates the 
average of all distances in each field, regardless of number of measurements. This mechanism is controlled by 
checking the image number for each measurement. All measurement measured on the same image number are 
reported on the same line in the report. In this case you can think of Freeze/unfreeze as a new line in the report. 

3. Repeat step 1 and 2 above until you have measured the desired number of fields. In this report up to 7 fields can 
be included. 

4. In the Result Window (or from the case), select File->Create Excel Report. Select the Field Statistics.xlt report 
(found in C:\program files\Bildanalyssystem\Picsara\templates\Excel Report Templates) 

5. The final report looks like this. 

 

  

Example 2, Surface layer report (Nitro Carbon surface report) 

In this example the user wants to create a report that calculates the average thickness of a porosity layer. Also it should 
report the average substrate thickness. Typically the substrate is quite homogenous and can be measured as one 
measurement using the parallel lines tool, while the porosity layer varies heavily and an average of several distance 
measurements must be calculated. This procedure is typically performed over several fields of view. 

 

1. Measure the substrate thickness using the parallel lines tool 
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2. Measure the porosity layer on several places using the distance tool. (in this report up to 11 distance 
measurements can be measured per field) 

3. Unfreeze/Freeze (or load a new image). This is an important step in this example. Since this report calculates the 
average of the porosity layer, as all (but the first) distances in each field, regardless of number of measurements. 
This mechanism is controlled by checking the image number for each measurement. All measurements measured 
on the same image number are reported as the same field of view.  

4. Repeat steps 2 and 3 above until you have measured the desired number of fields. In this report up to 8 fields can 
be included.  

5. In the Result Window (or from the case), select File->Create Excel Report. Select the Nitrocarbon layer report.XLT 
report (found in C:\program files\Bildanalyssystem\Picsara\templates\Excel Report Templates) The final report 
looks like this. 

 

Example 3, K1C measurements 

K1C measurements are a special type of hardness measurements, normally performed on hard materials or ceramics. A 
K1C measurement typically consists of measuring the indents dimensions (D1 & D2) plus the vertical and horizontal 
length of the cracks, from the corners of the indent. In this example an average of 3 such indents are calculated. 

 

1. Set the length of the end-lines of the distance tool to a large number (such as 300). See Distance tool for more 
information. 

2. Click on the end-point of the left-most crack, and move the mouse to the start-point of the same crack, while 
pressing Ctrl on the keyboard. (This will make the line horizontal aligned). Release the mouse. 

3. Click on Ctrl, and measure D1 without releasing Ctrl. This will measure the horizontal distance from the previous 
end point, to the rightmost position of the indent. 

4. In the same manner, measure the right-most crack, followed by the top-most crack, the vertical distance of the 
indent and finally the bottom-most crack. 

5. Repeats step 2-4 up to 3 times. 

6. In the Result Window (or from the case), select File->Create Excel Report. Select the K1C Protocol.XLTreport 
(found in C:\program files\Bildanalyssystem\Picsara\templates\Excel Report Templates) 

7. The final report looks like this. 

 

Understanding Excel Reporting mechanism 

When creating a report from existing raw data, several steps are taken to format the final report. In order to control this 
process several settings are configurable.  

The general requirement is that a Excel template should include three pages, where page 2 is named "RawData" and 
page 3 is named "Instructions". 

 

The third page, instructions, serves as an instruction to Picsara which in it’s initial step of creating a report loads the 
settings. The settings must be stored in the second column (the B column) in the following order: 

 

RawDataPage: B1 The page where to copy the raw data. The raw data (from the result 
window) can be copied to page 1 or page 2 (RawData). Type the 
name of the page/sheet. 

RawDataFirstCell: B2 The cell where the raw data should start (on the selected page) 
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RunMacroAfterExport:
  

 

B3 Macro to run after raw data is copied to RawData page. Normally this 
macro moves selected portions of the RawData into the first report 
page. Also, it possible to do clean up work, erasing unwanted pages 
or cells. 

SetPage B4 Page to display upon completion 

CreateColumnHeaders B5 Type Yes or No, to indicate if the raw data column should be 
outputted with column headers. This can be useful if raw data is 
outputted directly to the report page 

CreateStatistics B6 Creates statistics for each column in the raw data table 

UseFixedPositions B7 Type Yes or No. Yes means that all columns in the Result Window 
are output, regardless if they are visible or not. No, means that raw 
data table should look identical with the Result Window. If you are 
using macros to format or copy data, you would normally prefer to 
have this setting to yes. This way a given result is always in the same 
column. Please observe that some system data, such as Image ID 
and calibration are far to the right in the spread sheet using Fixed 
positions. 

DeletePages B8 Delete this page upon completion. If to delete multiple pages, use a 
macro instead 

 

This is an example of a typical Instruction page.    
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This is an example of an output to the RawData page, with the settings in the image above.  
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The final result looks like this: 
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Understanding Excel Reporting mechanism 

When creating a report from existing raw data, several steps are taken to format the final report. In order to control this 
process several settings are configurable.  

The general requirement is that a Excel template should include three pages, where page 2 is named "RawData" and 
page 3 is named "Instructions". 

 

The third page, instructions, serves as an instruction to Picsara which in it’s initial step of creating a report loads the 
settings. The settings must be stored in the second column (the B column) in the following order: 

 

RawDataPage: B1 The page where to copy the raw data. The raw data (from the result 
window) can be copied to page 1 or page 2 (RawData). Type the 
name of the page/sheet. 
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RawDataFirstCell: B2 The cell where the raw data should start (on the selected page) 

RunMacroAfterExport:
  

 

B3 Macro to run after raw data is copied to RawData page. Normally this 
macro moves selected portions of the RawData into the first report 
page. Also, it possible to do clean up work, erasing unwanted pages 
or cells. 

SetPage B4 Page to display upon completion 

CreateColumnHeaders B5 Type Yes or No, to indicate if the raw data column should be 
outputted with column headers. This can be useful if raw data is 
outputted directly to the report page 

CreateStatistics B6 Creates statistics for each column in the raw data table 

UseFixedPositions B7 Type Yes or No. Yes means that all columns in the Result Window 
are output, regardless if they are visible or not. No, means that raw 
data table should look identical with the Result Window. If you are 
using macros to format or copy data, you would normally prefer to 
have this setting to yes. This way a given result is always in the same 
column. Please observe that some system data, such as Image ID 
and calibration are far to the right in the spread sheet using Fixed 
positions. 

DeletePages B8 Delete this page upon completion. If to delete multiple pages, use a 
macro instead 

 

This is an example of a typical Instruction page.    
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This is an example of an output to the RawData page, with the settings in the image above.  
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The final result looks like this: 
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Understanding Excel Reporting mechanism 

When creating a report from existing raw data, several steps are taken to format the final report. In order to control this 
process several settings are configurable.  

The general requirement is that a Excel template should include three pages, where page 2 is named "RawData" and 
page 3 is named "Instructions". 

 

The third page, instructions, serves as an instruction to Picsara which in it’s initial step of creating a report loads the 
settings. The settings must be stored in the second column (the B column) in the following order: 

 

RawDataPage: B1 The page where to copy the raw data. The raw data (from the result 
window) can be copied to page 1 or page 2 (RawData). Type the 
name of the page/sheet. 
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RawDataFirstCell: B2 The cell where the raw data should start (on the selected page) 

RunMacroAfterExport:
  

 

B3 Macro to run after raw data is copied to RawData page. Normally this 
macro moves selected portions of the RawData into the first report 
page. Also, it possible to do clean up work, erasing unwanted pages 
or cells. 

SetPage B4 Page to display upon completion 

CreateColumnHeaders B5 Type Yes or No, to indicate if the raw data column should be 
outputted with column headers. This can be useful if raw data is 
outputted directly to the report page 

CreateStatistics B6 Creates statistics for each column in the raw data table 

UseFixedPositions B7 Type Yes or No. Yes means that all columns in the Result Window 
are output, regardless if they are visible or not. No, means that raw 
data table should look identical with the Result Window. If you are 
using macros to format or copy data, you would normally prefer to 
have this setting to yes. This way a given result is always in the same 
column. Please observe that some system data, such as Image ID 
and calibration are far to the right in the spread sheet using Fixed 
positions. 

DeletePages B8 Delete this page upon completion. If to delete multiple pages, use a 
macro instead 

 

This is an example of a typical Instruction page.    
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This is an example of an output to the RawData page, with the settings in the image above.  
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The final result looks like this: 
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Understanding Excel Reporting mechanism 

When creating a report from existing raw data, several steps are taken to format the final report. In order to control this 
process several settings are configurable.  

The general requirement is that a Excel template should include three pages, where page 2 is named "RawData" and 
page 3 is named "Instructions". 

 

The third page, instructions, serves as an instruction to Picsara which in it’s initial step of creating a report loads the 
settings. The settings must be stored in the second column (the B column) in the following order: 

 

RawDataPage: B1 The page where to copy the raw data. The raw data (from the result 
window) can be copied to page 1 or page 2 (RawData). Type the 
name of the page/sheet. 
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RawDataFirstCell: B2 The cell where the raw data should start (on the selected page) 

RunMacroAfterExport:
  

 

B3 Macro to run after raw data is copied to RawData page. Normally this 
macro moves selected portions of the RawData into the first report 
page. Also, it possible to do clean up work, erasing unwanted pages 
or cells. 

SetPage B4 Page to display upon completion 

CreateColumnHeaders B5 Type Yes or No, to indicate if the raw data column should be 
outputted with column headers. This can be useful if raw data is 
outputted directly to the report page 

CreateStatistics B6 Creates statistics for each column in the raw data table 

UseFixedPositions B7 Type Yes or No. Yes means that all columns in the Result Window 
are output, regardless if they are visible or not. No, means that raw 
data table should look identical with the Result Window. If you are 
using macros to format or copy data, you would normally prefer to 
have this setting to yes. This way a given result is always in the same 
column. Please observe that some system data, such as Image ID 
and calibration are far to the right in the spread sheet using Fixed 
positions. 

DeletePages B8 Delete this page upon completion. If to delete multiple pages, use a 
macro instead 

 

This is an example of a typical Instruction page.    
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This is an example of an output to the RawData page, with the settings in the image above.  



Manual for Optilia Picsara v8.9 

84 

  

 

The final result looks like this: 



Add-on Modules 

85 

  

 

Measuring the Radius of an Object 

The Measuring Radius and Circle function requires the Analysis module. 

To measure the radius, area and perimeter of a circle: 

1. Select Measurements -> Radius. 
Or click the Radius button. 

2. Click and drag the left mouse button on the edge of an object. 

3. Extend the radius.  

4. Release the mouse button when the center of the circle is reached.  

5. The result will be displayed in the Status Bar. 

Measuring a Polygon 

The Measuring Polygon function requires the Analysis module. 
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To measure a polygon’s area and perimeter: 

1. Select Measurements -> Polygon. 

2. Locate a start point and click and drag the mouse along the edge of the polygon. Click each time to start a new 
segment. 

3. Continue until the polygon is complete 

4. When finished, right mouse click to close the polygon. Picsara automatically completes the last edge. 

5. The results will be displayed in the Status Bar.  

Measuring the Angle between two Lines 

The Measuring Angles function requires the Analysis module. 

To measure an angle between two lines: 

1. Select Measurements -> Angle. 
Or click the Angle button. 

2. Locate a start point and click and drag the mouse along the first line. 

3. Release the mouse and open the angle. 

4. Left mouse click to complete the measurement. 

5. The results will be displayed in the Status Bar. 

 

Deleting Measurements 

• Select Measurements -> Delete last measure to delete the last made measurement. 

o This will also delete the measurement from the result window and the current case (if any) 

• Select Measurements -> Clear measurements to clear all measurements from the screen. 

o This will NOT delete the measurements from the result window or the current case. 

• In the Result window, select File -> Delete all… to delete all measurements from both the screen and the result 
window. 

o This function is only available if the Analysis module is present. 

• In the Case Window, select Case -> Delete all results… to delete all results in the case and on the screen. 

o This function is only available if both the Analysis module and the Database module are 
present. 

 

The Object Analysis Module 
The Object Analysis Module, Overview 

Many features of an object can be measured automatically, saving time and providing reproducible results. Common 
features are area and perimeter, but more complex features such as length and shape can also be calculated. 
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Object result drop-down list in Result Window 
 

The principle for all automatic measurements is based on selecting objects to measure different gray tones. An object’s 
gray tone must differ from the background and other types of objects. This process is called thresholding. 

Picsara makes it easy to threshold an image. The user can view the effect that different threshold values have on an 
image. When the threshold is finished, all objects will be identified and can be calculated for area, perimeter, length etc.  

Only objects within the ROI (Region of interest) are calculated. Areas outside the ROI are not included in the calculation. 
By default, the ROI is the entire image window. To set a smaller area, use the ROI tools under the Measurements menu. 

To activate the threshold: 

1. Select Measurements -> Object measure...  
Or click the Object button 

2. The Set threshold dialog box will appear. 

  

3. Adjust the threshold settings to indicate what is included in the calculation. 

• Objects within the threshold range will be displayed as green. 

4. When satisfied with the threshold limits, click Calculate. 

• All objects will be identified and the calculations will be performed. 

 

Calculating Field and Object parameters 

In an Object measurement, objects are identified according to selected characteristics.  
To define the object characteristics: 

1. In the Set threshold dialog box click the Setup button. The Object analysis dialog box will open. 

2. In the Calculation tab, select the characteristics to calculate. 
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Check the associated box to activate the desired measurement.  

• Field measurements are calculated for the entire image (or interest area).  

• Object measurements are calculated for each identified object.  

• An object can be excluded if it falls outside a specific criterion.  

• All objects that are not excluded are called included objects. 

 

Field measurements that can be calculated: 

• Nr of objects:  The number of included objects in the interest area. 

• Area fraction:  The total area of included objects relative to the interest area. 

 

Object measurements that can be calculated: 

• Area:  The area (given in the current calibrated unit) of every object, excluding holes (if not filled). 

• Perimeter:  The perimeter (given in the current calibrated unit) of every object. A perimeter diagonal is 
approximated with the distance 1.42 (equal the square root of 2).  

• Length:  This is a measure of the true length of an object and is determined from the perimeter (P) and area (A) 
assuming that P = 2 (length + breadth) and A = length x breadth. This method is accurate for long thin objects. 

• Feret diameter:  The longest projected stretch for an object. Eight angles are tested. 

• Compactness:  Determined from the true perimeter (p) and the area (A), according to Compactness = p²/(4pA). 
This value is 1.0 for circular objects. The more convoluted the shape, the greater the value. 

• Center of gravity:  Are x,y coordinates that indicate the object’s center of gravity, defined as the mean value of the 
object’s pixel coordinates. 

• Position:  The objects top left pixel position. 

 

Excluded objects are displayed in red and included objects are displayed in green.  

To Change the display settings 

1. Select View Objects tab 

• Check to display objects with unique numbers, a cross in the center, with solid colors, or an outline 
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To set if an object should be considered as included or excluded after a measurement has been performed: 

1. Double-click with the left mouse button on the object in the main window. Then the Object Information 
dialog window opens. 

2. Make necessary changes. 

 

 

Please read Mathematical Foundations for a reference of formulas being used in Picsara. 

 

Excluding unwanted Objects 

Using gray tone threshold can make it difficult to select an object. Undesired objects can tag along in calculations. To 
prevent this, set criteria for objects that should be included in the result 

Example: 

The user wants to find and calculate the number of round objects as well as the individual area and perimeter and the 
total area. 

After thresholding identified seven objects, four objects were determined non-interesting. 

Because Picsara calculates area for all the objects, the 4 non-interesting objects are added to the calculations. 

Criteria, such as size, can be applied to limit the objects of interest. For example, if searching for objects larger than 1000, 
all objects smaller than 1000 (pixels or calibrated units) will be excluded.  

To set criteria: 

1. Area criterion: Select Exclude... for Area. The Exclude object dialog box will appear. This will work the 
same for any of the listed measures. 

  

2. Fill in the dialog based on the criteria of interest. Mark the associated checkboxes next to the selected 
criteria. 
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3. Click OK to close the Exclude object and Object Analysis dialog boxes. Perform the calculation. Only 
objects that met the criteria are included in the measurement. 

4. Click Remove all criteria to deactivate the criteria function for all measures or adjust each measure 
individually. 

Reviewing Results of an Individual Object 

It is possible to view the properties and measurement results for an individual object after an Object measurement has 
been performed. The green overlay must be present; the Object measure is still active in the main window.  

Click on an object to open the Object Information dialog window and view the raw data. When an object is marked its 
surface will get a brighter overlay. Changes can be made to the object status, included or excluded, in the Object 
Information dialog window. This applies to both included and excluded objects. 
 

 

Example where an object has been clicked and the Object Information dialog is opened 
 

The Hardness Measurements Module 
The Hardness Measurements Module, Overview 

Picsara supports interactive measurements of Vickers and Knoop indents. The testload used and the type of indenter, 
have to be specified in the system settings. Once these parameters are setup, you can quickly measure any number of 
indents and have the results logged to the result window (if you have the database module, results can also be logged in 
an open Case). From here you can print a report with hardness values and statistics such as mean hardness, min/max 
hardness and more. 

 

How to Measure Hardness 

To measure hardness according to Vickers/Knoop: 
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1. Select File -> System preferences... -> Measurements settings. 

2. Set the load and type of indenter being used. 

3. Select Measurements -> Hardness, or click the Hardness button. A cross will appear. 

4. Click and drag the cross to the center of the indent.  

5. Left mouse click on the left side of the indent. A square or boundary lines will appear.  

6. Move the sides of the square so they touch the edge corners of the indent. 

7. The results will be displayed in the Status Bar. 

 

For more information on formulas being used for calculation of Vickers and Knoop values please see Mathematical 
Foundations. 

Note: By right-clicking the mouse, the hardness measure will be cleared; the hardness result saved and a new 
measurement can be performed. 

The Grain Size Measurements Module 
The Grain Size Module, Overview 

Picsara supports two types of grain size measures: Grain size by line intersections according to ASTM E-112 and Grain 
size by circular intersections according to ASTM E-112. The latter method is intended for Rolled steel or any product with 
non-symmetrical grains. 

Tip: An alternative way of measuring grain size is to compare images to known reference images. Create a 
"Compare images" file by opening the "Compare images" window and drag each (calibrated!) ASTM reference 
image into it. Save the file (the file extension for these files is .CMP) and have it open in the Compare images 
window. In the Compare Images Window, choose View->Scale as current magnification to make the ASTM 
reference images to be displayed with the same magnification as the image in the main window. 

 

Note:  The ASTM reference image suite is copyright protected and thus not shipped with Picsara. You will need to 
obtain the images from ASTM. 

Measuring Grain Size using Linear Tool 

The Linear Grain size tool is normally used to measure grain size on material such as steel with relatively symmetrical 
grains.  

 

To measure the grain size according to ASTM E-112 using the linear tool:   

 

1. Select Measurements -> ASTM E-112 (line intercept) 

• Or click the ASTM E-112 (line) button. 

• Within a measurement several calculations can be made, they are called ASTM lines. 

2. Click and drag the left mouse button to draw a line. 

• The line/lines should be randomly drawn. 

3. Click along the line where the grain boundaries intersect the line. 
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4. Right mouse click to finish measuring the first line. 

5. Click and drag the left mouse button to draw an additional line and make more measurements. 

6. Continue until all measurements are made. 

7. Right mouse click twice when finished. 

8. The results will be displayed in the Status Bar. 

 

Please read Mathematical Foundations for a reference of formulas being used in Picsara. 

 

 

Measuring Grain Size using Circular Tool 

The Circular Grain size tool is normally used to measure grain size on rolled steel, or other forms where the grains are 
non-symmetrical. For example, a case where the grains are oval shaped.   

 

To measure the grain size according to ASTM E-112, using Circular Tool: 

 

1. Select File -> System preferences... -> Measurements settings. 

2. Set the radius of the circle overlay based on the approximate grain size. 

3. Select Measurements -> ASTM-E112 (circle intersections). 

• Or click the ASTM E-112 (circle) button.  

4. A circle with the predefined radius will appear. 

5. Left mouse click to mark the intersections of the grain boundaries with the circle. 

6. Continue until all measurements are made. 

7. Right mouse click twice when finished. 

8. The results will be displayed in the Status Bar. 

 

Please read Mathematical Foundations for a reference of formulas being used in Picsara. 

 

The Welds Measurements Module 
The Welds Measurement Module, Overview 

Picsara supports three different ways to measure welds:  Weld S-Measure,  
Weld A-Measure, and Weld Full-Measure. 

 

The Welds module in Picsara has interactive measurement tools for the two most common measurements made on 
welds: the A-measure and the S-measure, also known as the "effective A-measure". These interactive tools are the 
quickest way to obtain a specific measurement result for a weld.  
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If a complete characterization of a weld is needed, the "Full measure" tool is recommended. This tool requires you to mark 
the boundary of the weld, and the original locations of the welded plates. In return, it will automatically calculate a wide 
array of characteristics for the weld, such as the total area, the area of sub-regions, the depth of penetration into the 
plates, the intersected angles and of course the A-measure and the S-measure.  

 

 

Measuring the S-Measure 

To measure a weld according to the S-measure (defined as the effective weld depth),  

1. Select Measurements -> Weld (S-measure). 

• Or click the Weld (S) button. 

• The S-measure can discover the smallest dept. 

2. Left mouse click and mark the smallest depth. 

3. Drag the circle out to the edge of the object. Release the mouse. 

4. The results will be displayed in the Status Bar. 

Measuring the A-Measure 

To measure a weld according to the a-measure: 

1. Select Measurements -> Weld (A-measure). 

• Or click the Weld (A) button. 

2. Draw two support lines that mark the original material area. 

3. A "T" will appear. Position this T over the smallest depth. 

4. The results will be displayed in the Status Bar.  

Measuring all Weld properties 

Weld Full measures most of the defined properties of a weld.  
 

  

Sketch of a full Weld measurement 
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To measure a full weld: 

1. Select Measurements -> Weld (full measure) 

• Or click the Weld (All) button. 

2. Left mouse click on the edge of the weld nugget. Repeatedly left click to draw line segments that outline the weld 
area. 

3. Right click when complete. 

4. Draw two intersecting lines that follow the original base material. 

5. Weld Full can calculate (see the above image for a sketch of a full Weld measurement): 

• A-measure:  The effective depth measure. 

• S-measure  

• Z1 and Z2:  Defined according to above diagram.  

• a2:  Is the penetration in the joined material. 

• i1:  Is the penetration in bit 1, at half depth. The depth can be adjusted manually to another position. The 
depth is marked in percent from the center. 

• i2:  Is the penetration in bit 2, at half depth. The depth can be adjusted manually to another position. The 
depth is marked in percent from the center. 

• i3:  Defined according to above diagram. 

• Lambda1:  The angle between one main axis and the area of the weld. 

• Lambda2:  The angle between the other main axis and the area of the weld. 

• Y1:  The area of surface Y1. 

• Y2:  The area of surface Y2. 

• Y3:  The area of surface Y3. 

• Y4:  The area of surface Y4. 

• Y5:  The area of surface Y5. 

6. The results will be displayed in the Result window. 

The Multi Focus Module 
The Multi Focus Module, Overview 

The multi focus function requires the multi focus module. 
 

The multi focus function is used to create an image with extended focus, out of several images on the same specimen, 
but with different focal point. It is assumed that the images are taken of a stationary specimen, through a microscope or a 
camera mounted on a rigid stand. 

A typical example would be creating an image of a mount with edge rounding or of any other uneven sample. 

Creating a Multi Focus Image 

The creation of a multi focus image is always made by adding two or more images to the multi focus window. 
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To open the window, select Image -> Create multifocus image or click on the multifocus icon. 

There are three ways to add images to the multi focus window 

1. Images can be dragged from the main window into the multi focus window (either a live or a frozen image). 

2. Grabbed from the main window by using the Grab image button in the multi focus window toolbar. 

3. Added from file by pressing the Add from file button. 

 

In the same moment an image is added, a new multi focus image is calculated and displayed. This is also true if you 
remove a single image. 

Remove all the images from the multi focus window by pressing the "Remove all images" button 

The results of the multi focus operation can be shown in the main window or in a separate window. Select Options-> 
Show images to select your preference. The final image can be stored in a case, exported and in general, handled the 
same way as any other image. 

 

Note: All images added to the stack of images must have the same resolution, calibration, and bit depth. 

 

Note: To create meaningful results it is of outmost importance that the specimen or the complete image does not 
move between each grab. 

 

Optimizing the quality of the Multi Focus Image 

A threshold value controlling the algorithm of the multi focus function can be changed in the multi focus Options dialog. It 
is normally better to use a large threshold value to obtain a good result for images with many details in many different 
focus levels, while in contradiction it is better to use a lower threshold value for images with few details in different focus 
levels. 

Select Options -> Object Size Threshold to set the Threshold value. It is recommended to use a value between 10 and 20. 

The Montage Module 
Montage Module, Overview 

We refer to "montage" as the act of merging two or more images into one large image. In Picsara, this is achieved without 
the need for a motorized stage. The resulting image remains calibrated, making it possible to do measurements as well. 

 

The montage function is used to stitch groups of images into one large image. This can be useful when the specimen 
does not fit into the field of view. Typical examples are a long crack in a steel material or a histological specimen where 
the zone of interest often is much greater than the field of view. 

The algorithm does not require that Picsara has a motorized stage, but the acquired images must have some overlap. In 
the first phase of stitching images, the images are matched to each other in respect of position. When all images are 
acquired, a resulting image is calculated, where the software tries to blend the overlap of images, in order to avoid a grid 
effect. 

 

Creating a Montage 

1. Open the Montage Window by selecting Image->Create Image Montage. 
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2. Add the first image, for instance by using drag-and-drop, to the center of the Montage Window. Or use File, Add 
image. 

3. Move your sample approximately three quarter of the image size in any direction, and drag a second image into the 
Montage window.  

4. Place the image, making the overlapping part of the images roughly fit.  

5. When releasing the image, the image is automatically fitted exactly into position, and you can continue with the 
next image.  

6. If the software cannot find a perfect fit, the image is placed exactly where you released it.  

7. It is possible to grab the image again and fine adjust the position. 

 

Images can be placed in any order, thus making it possible to create any size and form of an image. For instance it is 
possible to trace a crack or a nerve, resulting in a Y or snake shaped image. 

 

When all images are added, the final montage image is created by selecting Montage -> Create montage... In this step, 
the software tries to smooth the edges by blending the parts that overlap. Experiment with how much overlap is required 
for your optical system, in order to have a smooth transition between the images, and avoid a grid like effect. 

 

It is possible to set thumbnail size of images displayed in the montage window, and to view image borders of added 
images.  

Under the Montage menu: 

• It is possible to save montage to file.  

• It is also possible to undo montage. 

 

When images are added and placed into the montage window, their overlap is calculated automatically. By pressing the 
Shift key when placing the images, they can be placed manually. 

Montage Settings 

In the File menu, select Settings… 

 

Appearance 

The size of the displayed images in the montage window can be changed.  Enter a thumbnail size between 5 and 50%. 

 

Algorithm 

There are two possibilities to adjust algorithm settings for the montage function. 

1. Adjustment of the size of the search area an image is moved within to be stitched to underlying image/s:  
The chosen number of pixels is the number of pixels the image will be moved within in all four directions to find the 
best fit to the underlying image(s). The more pixels, the larger area will be when searchung, but in turn the 
processing time will be longer. 

2. Adjustment of the subsampling level: 
The greater number, the faster processing time, but there is a risk for poor matching if the image only contains 
small details. 
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Autocrop 

Check the autocrop box and enter the number of pixels to remove form each image. This may be helpful if the illumination 
is uneven. 
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Technical notes 

Image Formats 
Bellow is a short description of the most common image formats: 

• TIF (tif, tiff): A standardized, normally uncompressed format. Use this format if the image quality is more important 
than the file size. Images with this file format are usually quite big (about 10 times bigger than jpeg for instance). 
The format is commonly used and most imaging software supports this format. Picsara supports saving of 
uncompressed color images, and loading of all known variants of Tif files. 

• Jpeg (jpeg, jpg): A standardized, compressed format. Most commonly this format uses a destructive compression 
algorithm, which means the loaded image differs slightly from the original image. For instance the number of colors 
used is normally reduced, and a highly magnified image will show some "block" artifacts. For the normal human 
eye though, the difference between the original image and the compressed image is normally very little. The size 
of the final file is dependent on the Quality factor and the image content, but as a rule of thumb, it is about 1/10th of 
an uncompressed image. Picsara supports saving and loading of both lossy and lossless images. For saving, the 
file compression size can be selected in the System Preferences dialog box, under the General Tab. 

• Bitmap (bmp): An uncompressed format normally used for hand made drawings. Not very common for photo type 
images. Bitmap is a simple image format, and thus supported in most imaging applications. Picsara supports 
saving of Windows Bitmaps. It supports loading of most Bitmap formats, including OS/2 bitmap etc. Normally you 
should avoid using this format for saving images.  

• Buehler IMG (img): A Buehler proprietary image format used in earlier versions of Buehler Omnimet applications. 
Picsara supports loading of this format. 

• Ping (png): A compressed image file format, often used in web page production. Suitable for man made images, 
and less appropriate for photo style images. Picsara supports loading of this file format. 

• Kodak Photo CD (pcd): Kodak photo format, a multi resolution proprietary image format. Picsara supports loading 
of images with this format. If several images (resolutions) are stored in one file, the image with the highest 
resolution is loaded. 

• Dicom (dic, dcm). A complex image format intended for medical use. It supports a wide variety of internal formats 
(compressed/uncompressed, various bitdepths) and can also contain predefined tags with patient information. 
Picsara supports loading of Dicom images but will disregard information found in tags. 

 

 

 

Start switches 
Start switches are used to instruct Picsara to start up in a given mode, and/or to login silently (without the need of typing 
username and password) into a database. Normally this is used when Picsara is launched from another application, or is 
part of a system integration.  

Generally spaces, special symbols such as "/" and "=" and other white characters, are not accepted in any string, unless 
indicated. 

 

• /d=Database  
Default database to open after starting the application. 
The name refers to the name of the connection, not the name of the actual database file. See Managing 
Connections to Databases for more information. 
Example: /d=DemoDatabase 

• /u=UserName  
Use together with /x to login silently into database. 
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• /x=Password  
Use together with /u to login silently into database. 

• /a=Department  
Department to use. The name refers to the department’s short name. 

• /tFieldName="String" 
Populates the input field called FieldName to the text String (both when searching for case, and when creating 
case). The String can include space and other special symbols. Only use this switch with text controls. 

• /iFieldName="Number" 
Populates the input field called FieldName to Number (both when searching for case, and when creating case). 
Only use this switch with Number controls. 

• /bFieldName="0"|"1" 
Populates the input field called FieldName to 0 or 1 (both when searching for case, and when creating case). Only 
use this switch with Yes/No controls. 

• /g=UserDefinedSearch 
Call the user defined search with name "UserDefinedSearch" when+ launching Picsara. 

• /v=ExternalID  
Set the ExternalID of all cases created under this session to ExternalID. Use this data to store an external value 
with the case, for instance an external ID from a host system. 

• /f=FileName  
Use parameter file rather than start switches. File is the fully qualified path and name of the file that stores all 
parameters. Parameters are identical with start switches. A parameter file is always deleted after launching the 
application. In a parameter file, each start switch should be on a new line. 

• /r  
Replace "_" in FieldName with space. 

• /s  
Sets Picsara in search mode. In this mode it is not possible to create new cases. 

• /c  
Sets Picsara in create mode. In this mode a new case is created automatically. 

• /readonly  
Sets all field values that are entered after this flag to read-only. The user will thus not be able to change the value 
for these fields 

• /endreadonly  
This flag is used to end a sequense of read-only fields. 

• /useinsearch, indicates that the following fields are to be defaulted as values in the search case dialog. Can be 
combined with the /readonlykey 

• /enduseinsearch, the following fields are not to be defaulted in the search dialog 

• /m  
Forces Picsara to run as top-most 

• /hidechangedepartment, hides the button/menu for "change department" 

• /hidecreatecase, hides the button/menu for "create case" 

• /hideserachimage, hides the button/menu for "search image" 

• /hidesearchcase, hides the button/menu for "search case" 

• /hideopendatabase, hides the menu for "open database"§ 

• /allowmultipleinstances, allows multiple instances of Picsara. 
Note! When multiple instances is allowed no cameras can be used together with Picsara! 
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Example: 

Picsara.exe /r /d=MyDatabase /u=Fred /x=Fred123 /useinsearch /tPatientID="121212-1212" /enduseinsearch 
/tPatient_Name="Bill Waterman" /bResident=1 

Opens up the database "MyDatabase" using account "Fred" with password "Fred123". If the user creates a new case, the 
case will be pre-filled with 121212-1212 as PatientID and Bill Waterman as Patient Name. Also the checkbox Resident will 
be checked. If pressing "search case" the search dialog will be pre-filled with 121212-1212 as PatientID 

 

Example 2: 

Picsara.exe /r /d=MyDatabase /u=Fred /x=Fred123 /readonly /tPatientID="121212-1212" /endreadonly 
/tPatient_Name="Bill Waterman" /bResident=1 

Same as earlier example but sets the field "PatientID" as read-only 

 

Registry settings 
The registry is a database in the local computer that stores both user settings and shared settings (that is common 
settings that all users share) 

The settings can be viewed and edited through a software called regedit.exe, that is preinstalled with windows. 

User settings for the currently logged in user (or user profiles) is stored in the 
HKEY_CURRENT_USER\Software\Bildanalyssystem key (folder).  

Shared settings (or computer settings) are stored in the HKEY_LOCAL_MACHINE\Software\Bildanalyssystem key. 

As a rule of thumb, most settings are stored in the HKEY_CURRENT_USER folder, for instance tool bar positions, last 
used color on pens, dialog positions and other personal settings. Shared settings, such as input unit configuration, 
calibrations, hardware settings etc are stored in the HKEY_LOCAL_MACHINE. 

By default in Windows, all keys in HKEY_LOCAL_MACHINE is write protected for everyone but the local administrator. 
This means only administrators can changes shared settings. By default though, the key where input devices and 
calibrations are changed (HKEY_LOCAL_MACHINE\Software\Bildanalyssystem\Picsara\Settings, are changed to be write 
enabled for everyone. If this is not the preferred behavior, please use regedit to change permissions on this key. 

Meaning E P A  

HKEY_LM\Picsara\Settings\Data X X X All information regarding the 
input device configuration and 
it’s calibrations. 

HKEY_LM\Picsara\Authorization\LicenseNumber   X The license number for Picsara 
on this machine. 

HKEY_LM \Picsara\Authorization\LicenseType   X 0= Demo license, 1 = Client 
license. 2 = Server License 

HKEY_LM \Picsara\Authorization\Server   X If Server License, server name 
of Server License computer 
(SQL server) 

HKEY_LM \Picsara\Authorization\ComputerName   X If Server License, name to be 
used when registered on Server 
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License (by default the 
computers default name.) 

HKEY_LM \Picsara\Authorization\Ver2SiteCode   X If Client License, Site Key to 
unlock the client. 

HKEY_LM \Picsara\General\Password   X Password to protect system 
settings and calibrations 

HKEY_LM \Picsara\General\SecureInformationMode  X X 0 = No, 1 = Yes 

HKEY_LM \Picsara\Twain X X X Various twain camera settings 

HKEY_LM \General\Database  X X All database connection 
configurations.  (X=0-20) 

DatabaseNameX  =Name of 
connection 

DatabaseTypeX 1 = ODBC type, 
2 = PictSure type 

ODBCNameX Name of ODBC 
connection for this connection 

PictSureAddressX Name of 
PictSure server 

PictSurePortX Port that PictSure 
server listens to. Default 4800. 

The last connection +1 must be 
blank, for instance if there is 
only one database connection 
(assume DatabaseName0 = 
MyConnection), 
DatabaseName1 must be blank! 

HKEY_LM\Picsara\MonitorDrive X X X Settings on how to monitor 
drives and memory cards 

HKEY_LM\Picsara\ExternalButton\ComPort X X X Com port for External button 

HKEY_LM\Picsara\ExternalButton\Enable X X X 0=Disable  1 = Enable 

HKEY_LM\Picsara\ExternalButton\Action1 X X X Action for button1 

HKEY_LM\Picsara\ExternalButton\Action1 X X X Action for button1 

HKEY_LM\Picsara\HotKey\Action X X X Action for hotkey 

     

 

HKEY_LM Means HKEY_LOCAL_MACHINE 

E = Permission for Everyone 

P = Permission for PowerUsers 

A = Permission for Administrators 
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Note: Be careful when manipulating with the registry settings. By changing or deleting the wrong settings you can 
damage your computer. 

Tip: By deleting the complete HKEY_CURRENT_USER\Software\Bildanalyssystem, the default settings will be re-
created when the application is launched next time. 

 

Registry settings 
The registry is a database in the local computer that stores both user settings and shared settings (that is common 
settings that all users share) 

The settings can be viewed and edited through a software called regedit.exe, that is preinstalled with windows. 

User settings for the currently logged in user (or user profiles) is stored in the 
HKEY_CURRENT_USER\Software\Bildanalyssystem key (folder).  

Shared settings (or computer settings) are stored in the HKEY_LOCAL_MACHINE\Software\Bildanalyssystem key. 

As a rule of thumb, most settings are stored in the HKEY_CURRENT_USER folder, for instance tool bar positions, last 
used color on pens, dialog positions and other personal settings. Shared settings, such as input unit configuration, 
calibrations, hardware settings etc are stored in the HKEY_LOCAL_MACHINE. 

By default in Windows, all keys in HKEY_LOCAL_MACHINE is write protected for everyone but the local administrator. 
This means only administrators can changes shared settings. By default though, the key where input devices and 
calibrations are changed (HKEY_LOCAL_MACHINE\Software\Bildanalyssystem\Picsara\Settings, are changed to be write 
enabled for everyone. If this is not the preferred behavior, please use regedit to change permissions on this key. 

Meaning E P A  

HKEY_LM\Picsara\Settings\Data X X X All information regarding the 
input device configuration and 
it’s calibrations. 

HKEY_LM\Picsara\Authorization\LicenseNumber   X The license number for Picsara 
on this machine. 

HKEY_LM \Picsara\Authorization\LicenseType   X 0= Demo license, 1 = Client 
license. 2 = Server License 

HKEY_LM \Picsara\Authorization\Server   X If Server License, server name 
of Server License computer 
(SQL server) 

HKEY_LM \Picsara\Authorization\ComputerName   X If Server License, name to be 
used when registered on Server 
License (by default the 
computers default name.) 

HKEY_LM \Picsara\Authorization\Ver2SiteCode   X If Client License, Site Key to 
unlock the client. 

HKEY_LM \Picsara\General\Password   X Password to protect system 
settings and calibrations 
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HKEY_LM \Picsara\General\SecureInformationMode  X X 0 = No, 1 = Yes 

HKEY_LM \Picsara\Twain X X X Various twain camera settings 

HKEY_LM \General\Database  X X All database connection 
configurations.  (X=0-20) 

DatabaseNameX  =Name of 
connection 

DatabaseTypeX 1 = ODBC type, 
2 = PictSure type 

ODBCNameX Name of ODBC 
connection for this connection 

PictSureAddressX Name of 
PictSure server 

PictSurePortX Port that PictSure 
server listens to. Default 4800. 

The last connection +1 must be 
blank, for instance if there is 
only one database connection 
(assume DatabaseName0 = 
MyConnection), 
DatabaseName1 must be blank! 

HKEY_LM\Picsara\MonitorDrive X X X Settings on how to monitor 
drives and memory cards 

HKEY_LM\Picsara\ExternalButton\ComPort X X X Com port for External button 

HKEY_LM\Picsara\ExternalButton\Enable X X X 0=Disable  1 = Enable 

HKEY_LM\Picsara\ExternalButton\Action1 X X X Action for button1 

HKEY_LM\Picsara\ExternalButton\Action1 X X X Action for button1 

HKEY_LM\Picsara\HotKey\Action X X X Action for hotkey 

     

 

HKEY_LM Means HKEY_LOCAL_MACHINE 

E = Permission for Everyone 

P = Permission for PowerUsers 

A = Permission for Administrators 

 

 

Note: Be careful when manipulating with the registry settings. By changing or deleting the wrong settings you can 
damage your computer. 
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Tip: By deleting the complete HKEY_CURRENT_USER\Software\Bildanalyssystem, the default settings will be re-
created when the application is launched next time. 

 

Mathematical Foundations 
This tech note documents the formulas being used for various image analysis tasks.  

 

Hardness testing  

Vickers hardness value 

HV  = 1854.4 * m / d2 

 

Where: 

HV = Vickers hardness 

m = Testload, in gf 

d = (d1+d2)/2 

d1 = First diagonal, in micrometers 

d2 = Second diagonal, in micrometers  

 

Knoop hardness value 

HK  = 14229 * m / d2 

 

Where: 

HK = Knoop hardness 

m = Testload, in gf 

d = Diagonal, in micrometers 

 

Grain size measurements: 

Linear Grain size calculation: 

G = Average grain diameter 

ASTM  = -6.643856 * log10( G / 1000 ) – 3.288 

 

Where: 

G = d / I 

d = Total length of the lines, in micrometers 
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I = Number of intersections on the lines 

 

Circular Grain size calculation: 

ASTM = -6.643856 * log10( G / 1000 ) - 3.288 

 

Where: 

G = Average grain diameter 

r = Radius of the circle, in micrometers 

I = Number of intersections on the lines 

 

 

Object measurements: 

The following measures are derived from the perimeter and the area: 

A  = Area 

 

Where: 

Area is the total number of pixels multiplied by the pixel height and the pixel width. 

 

P  = Perimeter 

Where: 

Perimeter is the approximate length around the object. Diagonals count as√2 pixels. 

 

C  = Compactness = P2/(4*Π*A) 

 

Where: 

P  = Perimeter 

A  = Area 

 

Length (L) and breadth (B) are derived from the perimeter (P) and the area (A).  

 

L   = P/4 + √( (P/4)2 - A ) 

B   = P/4 - √( (P/4)2 - A ) 

 

In cases where the term inside the root is negative, these two measures are undefined and Picsara will report 0. 
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Formula is a result of the two equations: 

 

Perimeter = 2(Length+Breadth) 

Area  = Length*Breadth 

 

Observe: 

This formula assumes that Breadth is relatively small compared to Length, and is to be considered as a statistical function 
that is only reliable on thin objects. 

 

Max Feret diameter 

The max Feret diameter can be described as the largest projection of the object when seen from a number of different 
angles. It is computed by rotating the object and calculating its projection on the X-axis for each angle of rotation. The 
more angles that are used, the more accurate the value.  

On most objects the Feret diameter can be determined accurately even with a fairly low number of angles. Picsara uses 8 
angles, which gives an accurate estimation of the Feret diameter in most cases. 

 

 

 

What is DirectX / DirectShow 
DirectShow is one part of the DirectX software. DirectX is developed by Microsoft and DirectShow is currently the fastest 
growing camera interface technology.  

Earlier generations of digital cameras did not have a standardized interface towards the software. Therefore each camera 
manufacturer had to develop their own software interface, which only worked for a few software programs. Inversely an 
application only had support for a few cameras. These problems are solved with DirectX/DirectShow, where all cameras 
have the same "appearance". The unique characteristics for each camera are converted through a driver (WDM driver), 
which normally comes with the camera. 

DirectShow enabled software works with all DirectShow compatible cameras. Most cameras manufacturers now provide 
DirectShow drivers to their cameras. 

1. DirectShow is: 

• Very stable. 

• Very flexible.  

• Integrates great into any imaging software. 

• Free of charge. 

DirectX also introduces filter technology, making it possible to add real-time image filters to a video stream. The focus 
window and over/under exposure warning filters are examples of filters used in Picsara. 
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What is a WDM Driver 
WDM stands for Windows Device Driver Model. It is one of the core components of DirectShow. The WDM driver 
translates the signal from the camera into a format understood by DirectShow.  

Every DirectShow compatible device has a WDM driver. In some cases the WDM driver is preinstalled. For other devices 
a WDM driver needs to be installed before it can be used. 

DirectX does not dictate the quality of the video stream. The standard can be used for everything from simple low-cost 
web cameras to specialized high-end cameras.  

DirectX does not dictate the hardware used to stream video data, an USB2 (with 480Mbits/sec) or FireWire 
(400Mbits/sec) can be used. 

If the WDM driver is not already installed, it must be installed before using a DirectShow compatible camera. 

 

How to Build a Pedal 
A pedal can be configured to suit the needs for the user. One or two pedals can be connected to Picsara simultaneously, 
allowing the pedal to be programmed for different actions.  

 

A "press" signal is created by shortcutting pin 7 and Pin 8 on the RS-232 port for at least 50 ms. 

 

 

How to build article with Article no: H-PEDAL1 

 

Elfa art no: 35-887-12,  foot pedal 1 pole 

Elfa art no: 44-130-43,  D-sub cover 9 pole yellow 

Elfa art no: 44-055-02,  connector DE-09S-P-F 9 pole 

 

 

Procedure: 

 

Cut blue cable. 

Cut black and brown cable to about 1.5 cm length. 

Peel and take off a few "threads".  

Solder black cable to Pin 7. 

Solder brown cable to Pin 8. 

Use tube to protect pin 7 and 8 from each other! 

 

To line 2: 
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Close cover 

How to Develop a Lookup DLL 
A lookup DLL is used to lookup data in an external database, for instance to lookup a person’s name and address, given 
the social security number. 

 

The easiest way of creating a new DLL is to create one from the skeleton DLL provided with Picsara. The DLL solution, is 
developed using Microsoft Visual Studio .NET 2003 in C++. The solution can be found as a zip file in the Picsara \Appdir 
folder, and is named LookupDLL_Skelleton.zip. 

 

This document has no intention of explaining all details of how to create a DLL, but assumes the reader has knowledge in 
C++ programming and Visual Studio. Unzip the file into an empty folder and double click the .sln file.  

 

Basically the DLL consists of one C function: 

 

BOOL WINAPI LookupField( CQueryFieldsType& QueryFields ) 

 

The function is called when the user presses the Sync button.  

 

As an input the function takes QueryFields.QueryField which holds the name of the control. The function can fill the 
Result list with new values to be sent back to Picsara. 

 

For instance: 

Assume the input field PatientID is attached with PatientLookup.DLL 

 

Picsara will call the LookupField function, where the QueryField member of QueryFields is equal to "PatientID". The 
function is implemented to supply the list with appropriate name and address for this PatientID. This logic could for 
instance be implemented as a SQL Query against a Patient database. 

 

 

The function SetParams is called to set parameters needed in the lookup algorithm, this could be data such as database 
name, user name and password etc. 

 

void WINAPI SetParams( LPCSTR szParams ) 
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What is a PictSure Server 
The PictSure server is a centralized server with built in security. It can handle a great number of users and many 
simultaneous active connections without losing performance.  

In the PictSure database it is possible to add and organize users and departments. The users can have different roles 
with different permissions in Picsara. See Working in a Multi-User environment for more information on users and roles.  
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Troubleshooting 

My DirectX Camera Does Not Work 
Generally if a DirectX device does not work, something is wrong with the WDM driver. Try the following: 

1. Make sure the camera has enough power. Note:  FireWire cameras cannot be powered by the mini-
connector often used on laptops. 

2. If using a USB2 port on a modern computer make sure the latest chipset drivers from Intel are installed. 
Without these drivers it will not work. 

3. Some USB2 devices works poorly if too many USB devices are shared on the same hub. 

4. Move the camera to another USB or FireWire port. Install the camera on every port it is used on.  

5. Some drivers do not work if not logged in as administrator. 

6. Uninstall and re-install the driver again. 

If DirectX camera still does not work, try it with another DirectX compatible software such as AmCap. AmCap is 
preinstalled with Picsara in the  
\Program files\Bildanalyssystem\ Picsara881\Apps folder. 

If the camera does not work in AmCap, consult the camera supplier or manufacturer. 

Low Frame rate with DirectX Device 
Most DirectX devices are quite CPU demanding. Make sure the computer fulfills the specification for the camera and has 
enough memory. 

Some devices can set image quality, which often affects the frame rate. Try different qualities and check if it makes a 
difference. See Video -> Adjust camera driver (Capture pin). 

Many drivers can set the video resolution and frame rate. Try a different setting and check if it makes a difference. See 
Video -> Set video input format...  

Make sure the latest chipset driver is installed (USB devices only). 

 

Fails to Register License over Internet 
Error message: "The license number you have entered does not exist" 

1. Verify your license number; it should be in the form ABCD-ABCD.  

2. This license number is not found among the registered licenses. You should contact your reseller 

 

Error message: "The license service is currently not available" 

1. Verify your internet connection. Open Internet explorer and type the following address: 
http://www.picsara.se/LicenseService//LicenseService.asmx . You should see the following page: 
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2. If not, you might be prohibited to connect to Internet by a firewall. 

3. If you can see the above screen and still get the error message, press back and try again a second time; the license 
server might respond to slow while your client gets a time-out.  

4. If you still get the same problem, contact your reseller and retrieve an activation code over the phone. You should 
have your license number ready. 

 

License code installed but no modules were activated. 

1. Make sure your license code is a Picsara license code. This problem can occur if typing an MHT code in Picsara 
or the opposite. 

 

 

Application crashes when starting 
1. If you have an analogue camera attached to the computer, check your frame grabber board and verify the Matrox 

installation. 

2. If you have a digital camera, check the camera vendors DirectX device drivers, some are buggy and crash if not 
connected. 

 

Images in database not found 
This error can occur when images are stored externally.  

The administrator configures how the storage should be done in the database. 

Images can be configured to be stored either internally or externally in the database. 
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When storing the images externally, a path to the storage directory must be entered. This path should be accessible from 
all computers that use the image database. If the database is used from more than one computer, make sure to enter the 
local path name in UNC format (\\MyServer\Images etc). The database keeps track of this path for each image.  

 

Erroneous measurements results 
1. Check calibration by measuring a known distance, for instance by using a measuring disc. Calibration needs to be 

done if the optical circumstances are altered i.e. a camera is replaced; an optical tube is replaced or altered etc. 
Please note that you need to have write-privileges in the registry (HKEY_LOCAL_MACHINE) 

2. Check that the correct input device is active. You can switch between input devices from the fifth pane from the right 
in the status bar. 

3. Check that the correct objective / zoom is chosen. 

 

Cases are opened as read only 
Cases are read-only under the following circumstances: 

 

1. Your user account belongs to a role that does not have privileges to alter case and image information. 

2. The case you have opened is already opened by another user. 

3. The case you have opened was opened with your account when the software was abnormally closed. 

 

Exported images are not visible in Internet Explorer 
If Jpeg compressed images are not visible with Internet Explorer or other imaging products, check your compression 
factor settings under File->System Preferences->General Settings.  

A value between 1 and 99 saves the image as a lossy jpeg which is a jpeg format that most imaging software can show. 
Saving a jpeg image with compression factor 100 gives a lossless jpeg file. Lossless jpegs do not lose any of the image 
information during the compression algorithm. But lossless jpegs cannot be read by common imaging software. 
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